Bug 1002661 - [RHS-C] Version in API is wrong
[RHS-C] Version in API is wrong
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 12:52 EDT by Spenser Shumaker
Modified: 2015-05-15 14:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: cb8
Doc Type: Bug Fix
Doc Text:
Previously, incorrect version details were displayed in the API listing. Now, with this update, the correct version details are set to display in the API listing.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:36:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Downstream only patch (2.10 KB, patch)
2013-11-09 06:51 EST, Shubhendu Tripathi
no flags Details | Diff

  None (edit)
Description Spenser Shumaker 2013-08-29 12:52:07 EDT
Description of problem:
<full_version> in api is wrong

Version-Release number of selected component (if applicable):
2.1

How reproducible:
Always

Steps to Reproduce:
1.query the rhsc REST api "/api"
2.
3.

Actual results:
<version major="3" minor="3" build="0" revision="0"/><full_version>2.1.0.0</full_version>

Expected results:
<version major="3" minor="3" build="0" revision="0"/><full_version>3.3.0.0</full_version>

Additional info:
Comment 2 Shubhendu Tripathi 2013-11-09 04:31:14 EST
For RHSC, the full version should be something like 2.1.<Revision>.<Build> id and accordingly the values of major, monir, revision and build should be populated.
Comment 3 Shubhendu Tripathi 2013-11-09 06:51:42 EST
Created attachment 821863 [details]
Downstream only patch
Comment 4 Prasanth 2013-11-19 04:03:47 EST
Verified as fixed in cb8

Following is the relevant output from cb8 build:

------
<product_info>
<name>Red Hat Storage Console</name>
<vendor>Red Hat</vendor>
<version major="2" minor="1" build="2" revision="0"/><full_version>2.1.2-0.24.master.el6_5</full_version>
</product_info>
------
Comment 5 Shalaka 2014-01-07 05:34:00 EST
Please review the edited DocText and signoff.
Comment 6 Shubhendu Tripathi 2014-01-07 07:13:31 EST
Doc text looks fine
Comment 8 errata-xmlrpc 2014-02-25 02:36:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.