Bug 1002688 - SELinux is preventing /usr/sbin/asterisk from 'read' accesses on the file cdr.db.
SELinux is preventing /usr/sbin/asterisk from 'read' accesses on the file cdr...
Status: CLOSED DUPLICATE of bug 1002689
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:97c39dc729366904bc4b096f13c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 13:42 EDT by Jared Smith
Modified: 2013-08-30 08:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 08:44:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2013-08-29 13:42:26 EDT
Description of problem:
Compiled Asterisk (latest from the 1.8 branch) from scratch and then started it.  Looks like it's trying to access a file that SELinux isn't setup to correctly manage access to.
SELinux is preventing /usr/sbin/asterisk from 'read' accesses on the file cdr.db.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that asterisk should be allowed read access on the cdr.db file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep asterisk /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:asterisk_t:s0
Target Context                system_u:object_r:asterisk_log_t:s0
Target Objects                cdr.db [ file ]
Source                        asterisk
Source Path                   /usr/sbin/asterisk
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.9-200.fc19.x86_64 #1 SMP Wed
                              Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-08-29 13:40:36 EDT
Last Seen                     2013-08-29 13:41:05 EDT
Local ID                      1e8031b7-9fef-4d68-806c-c997ca9b6218

Raw Audit Messages
type=AVC msg=audit(1377798065.569:593): avc:  denied  { read } for  pid=25743 comm="asterisk" name="cdr.db" dev="dm-2" ino=2499455 scontext=system_u:system_r:asterisk_t:s0 tcontext=system_u:object_r:asterisk_log_t:s0 tclass=file


type=SYSCALL msg=audit(1377798065.569:593): arch=x86_64 syscall=open success=no exit=EACCES a0=23a3640 a1=0 a2=fffffffffffffff3 a3=1 items=0 ppid=25741 pid=25743 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=asterisk exe=/usr/sbin/asterisk subj=system_u:system_r:asterisk_t:s0 key=(null)

Hash: asterisk,asterisk_t,asterisk_log_t,file,read

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.9-200.fc19.x86_64
type:           libreport
Comment 1 Lukas Vrabec 2013-08-30 08:44:37 EDT

*** This bug has been marked as a duplicate of bug 1002689 ***

Note You need to log in before you can comment on or make changes to this bug.