Bug 1002696 - Potential conflict with renaming versions of ovirt jars
Potential conflict with renaming versions of ovirt jars
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Shubhendu Tripathi
RHS-C QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 13:56 EDT by Spenser Shumaker
Modified: 2015-08-28 06:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 06:11:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Spenser Shumaker 2013-08-29 13:56:24 EDT
Description of problem:

I have noticed a possible maven conflict with renaming only the versions of ovirt jars.  For example, the "/org/ovirt/engine/core/utils/2.1.0/utils-2.1.0.jar" used by RHSC.  The very similar (if not the exact same) version of this jar used by RHEV is "/org/ovirt/engine/core/utils/3.3.0/utils-3.3.0.jar".  By changing only the version this causes a conflict in maven repositories once versions start overlapping, especially for developers that may be building both rhevm and rhsc.
Comment 2 Itamar Heim 2013-08-30 04:11:04 EDT
iirc, guidance was rhs-c needs to conflict with rhev-m as they can't be co-installed on the same machine.
Comment 3 Dusmant 2015-08-28 06:11:21 EDT
We are not planning to fix it. Hence closing this BZ. If you think, it's applicable for 3.x release and would have an impact on customer, pls. open up a new BZ with the appropriate version. Thanks, -Dusmant

Note You need to log in before you can comment on or make changes to this bug.