Bug 1002720 - REST request without authentication throws NPE in business-central
REST request without authentication throws NPE in business-central
Status: CLOSED DUPLICATE of bug 986208
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Marco Rietveld
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 15:05 EDT by Jiri Svitak
Modified: 2016-09-20 01:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 08:41:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (3.70 KB, text/plain)
2013-08-29 15:05 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-08-29 15:05:14 EDT
Created attachment 791940 [details]
server.log

REST request without authentication throws NPE in business-central.
JBWEB000236: Servlet.service() for servlet javax.ws.rs.core.Application threw exception: java.lang.NullPointerException

I think it will be better if the application would react in a better way than NPE and server error 500. More meaningful exception could be thrown in server log and HTTP status 401 Unauthorized could be returned.

To reproduce:
1.) Download BPMS 6 ER2 and just run it with ./standalone.sh with default configuration. (Optionally you can add user guest, but the bug message remains the same.)
2.) Send a GET request to http://localhost:8080/business-central/rest/task/query?potentialOwner=guest&language=en-UK (for example using Firefox's RESTClient).
Comment 1 Ivo Bek 2013-08-30 08:36:06 EDT
This bug has been solving in BZ 986208.
Comment 2 Ivo Bek 2013-08-30 08:41:49 EDT

*** This bug has been marked as a duplicate of bug 986208 ***

Note You need to log in before you can comment on or make changes to this bug.