Bug 1002734 - ipxe rom 1af41000 fails to correctly DHCP the second time around
ipxe rom 1af41000 fails to correctly DHCP the second time around
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ipxe (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 16:13 EDT by lutter@watzmann.net
Modified: 2014-03-05 08:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-05 08:16:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iPXE script in which the DHCP request fails (666 bytes, text/plain)
2013-08-29 16:13 EDT, lutter@watzmann.net
no flags Details
libvirt network XML describing the network to which the VM is attached (683 bytes, text/xml)
2013-09-12 14:07 EDT, lutter@watzmann.net
no flags Details

  None (edit)
Description lutter@watzmann.net 2013-08-29 16:13:52 EDT
Created attachment 791951 [details]
iPXE script in which the DHCP request fails

Description of problem:

When I start a very basic KVM instance under libvirt (one NIC, set to PXE boot) iPXE successfully completes DHCP and then fetches my iPXE script (attached) from my tftp server. That script asks the VM to DHCP again on that interface; that second round of DHCP does not complete successfully - I can see the DHCPDISCOVER and DHCPOFFER in my log files, but the VM never sends a DHCPREQUEST (and there's then no subsequent DHCPACK)

If I replace the 1af41000.rom with the one from Fedora 18, this all works.
Comment 1 Cole Robinson 2013-08-31 15:16:23 EDT
I built an RPM with latest ipxe git, can you give that a spin and see if makes any difference?

http://koji.fedoraproject.org/koji/taskinfo?taskID=5877738
Comment 2 lutter@watzmann.net 2013-09-12 14:05:15 EDT
Unfortunately, this does not fix the issue for me - still the exact same symtpoms.

If it makes any difference, I am running this on a local libvirt network; network XML is attached. I use a VM with one NIC, connected to that network.
Comment 3 lutter@watzmann.net 2013-09-12 14:07:14 EDT
Created attachment 796961 [details]
libvirt network XML describing the network to which the VM is attached
Comment 4 Cole Robinson 2014-03-05 08:16:09 EST
With ipxe-20140303-1.gitff1e7fc7.fc20, this seems to be fixed. Please reopen if that's not the case.

Note You need to log in before you can comment on or make changes to this bug.