Bug 1002744 - [rhq-plugin] Fault count metrics are always 0
[rhq-plugin] Fault count metrics are always 0
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: JON (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER1
: 6.0.0
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 17:03 EDT by Viet Nguyen
Modified: 2015-08-02 19:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 14:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
EAP admin console (155.28 KB, image/png)
2013-08-29 17:04 EDT, Viet Nguyen
no flags Details
JON metric view (356.88 KB, image/png)
2013-08-29 17:05 EDT, Viet Nguyen
no flags Details

  None (edit)
Description Viet Nguyen 2013-08-29 17:03:29 EDT
Description of problem:

Fault count and Fault count per minute are not getting updated with actual values.  See attachments.



Version-Release number of selected component (if applicable):
1.1.0 snapshot

How reproducible:
100%

Steps to Reproduce:
1. Deploy helpdesk demo app
2. Hit helpdesk web service with multiple bad requests eg open a ticket with a blank id 
3. Review fault count in Admin Console and compare that with values in JON Switchyard metric view (make sure Fault count and count/minute metrics are enabled and set to a short interval eg 30 seconds)
Comment 1 Viet Nguyen 2013-08-29 17:04:26 EDT
Created attachment 791953 [details]
EAP admin console
Comment 2 Viet Nguyen 2013-08-29 17:05:50 EDT
Created attachment 791954 [details]
JON metric view
Comment 4 kconner 2013-09-05 18:29:11 EDT
How can this go from NEW -> VERIFIED without any work being done in development?
Comment 5 Varun Khurana 2013-09-06 10:43:45 EDT
There is a commit in https://github.com/knrc/rhq-switchyard-plugin (Change metrics to dynamic, fixes #3) 10 days ago. It seems to me that this bug has been fixed because of that.
Comment 6 Varun Khurana 2013-09-06 11:18:55 EDT
My bad....Moving the Status back to NEW to make sure the QE team verifies this bug in the official build....
Comment 7 kconner 2013-09-12 09:52:41 EDT
(In reply to Varun Khurana from comment #5)
> There is a commit in https://github.com/knrc/rhq-switchyard-plugin (Change
> metrics to dynamic, fixes #3) 10 days ago. It seems to me that this bug has
> been fixed because of that.

I do not believe this would have made any difference as it just changes the way in which the information is presented, not how it is retrieved.

I have tried to reproduce this issue but have not been able to, can you provide access to a system that demonstrates the problem?
Comment 8 Viet Nguyen 2013-09-12 15:47:18 EDT
I was not able to reproduce this in the latest switchyard plugin master build. Please mark as fixed so the bug remains on QE radar for verification.
Comment 9 kconner 2013-09-13 14:11:47 EDT
Closing as not a bug as the issue cannot be reproduced.

Note You need to log in before you can comment on or make changes to this bug.