This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1002791 - Cron can not execute scheduled jobs
Cron can not execute scheduled jobs
Status: CLOSED DUPLICATE of bug 1002153
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cronie (Show other bugs)
6.5
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Marcela Mašláňová
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-29 22:51 EDT by Hu Jianwei
Modified: 2015-07-13 01:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 04:18:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hu Jianwei 2013-08-29 22:51:09 EDT
Description of problem:
cron can not execute scheduled jobs

Version-Release number of selected component (if applicable):
kernel-2.6.32-415.el6.x86_64
crontabs-1.10-33.el6.noarch
cronie-1.4.4-10.el6.x86_64
cronie-anacron-1.4.4-10.el6.x86_64

How reproducible:
100%

Steps:
1.sign in using root user, and schedule one job, print "hello" to /root/1.log file per minute.
[root@amd-4450b-4-1 ~]# crontab -e
crontab: installing new crontab

[root@amd-4450b-4-1 ~]# crontab -l
*/1 * * * *  echo hello >> /root/1.log 

2. wait several mins, check the /root/1.log, no 1.log created in root dir, tail the log of crontab
[root@amd-4450b-4-1 ~]# tail /var/log/cron 
Aug 29 21:44:08 amd-4450b-4-1 crontab[9397]: (root) REPLACE (root)
Aug 29 21:44:08 amd-4450b-4-1 crontab[9397]: (root) END EDIT (root)
Aug 29 21:54:43 amd-4450b-4-1 crond[7761]: (CRON) STARTUP (1.4.4)
Aug 29 21:54:43 amd-4450b-4-1 crond[7761]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 9% if used.)
Aug 29 21:54:46 amd-4450b-4-1 crond[7761]: (CRON) INFO (running with inotify support)
Aug 29 22:01:01 amd-4450b-4-1 crontab[8285]: (root) LIST (root)
Aug 30 10:19:06 amd-4450b-4-1 crontab[10877]: (root) LIST (root)
Aug 30 10:19:48 amd-4450b-4-1 crontab[10920]: (root) BEGIN EDIT (root)
Aug 30 10:19:52 amd-4450b-4-1 crontab[10920]: (root) REPLACE (root)
Aug 30 10:19:52 amd-4450b-4-1 crontab[10920]: (root) END EDIT (root)

Actual results:
The scheduled job was not executed by system.

Expected results:
Should be like:
[root@localhost ~]# cat /root/1.log 
hello
hello
hello
hello
hello
hello
hello
hello

In /var/log/cron:
Aug 30 10:02:01 localhost CROND[9782]: (root) CMD (echo hello >> /root/1.log)
Aug 30 10:03:01 localhost CROND[9807]: (root) CMD (echo hello >> /root/1.log)
Aug 30 10:04:01 localhost CROND[9832]: (root) CMD (echo hello >> /root/1.log)
Aug 30 10:05:01 localhost CROND[9857]: (root) CMD (echo hello >> /root/1.log)
Aug 30 10:06:01 localhost CROND[9884]: (root) CMD (echo hello >> /root/1.log)
Aug 30 10:07:01 localhost CROND[9908]: (root) CMD (echo hello >> /root/1.log)
Aug 30 10:08:01 localhost CROND[9932]: (root) CMD (echo hello >> /root/1.log)

This issue can not be reproudced by:
cronie-1.4.4-7.el6.x86_64
crontabs-1.10-33.el6.noarch
cronie-anacron-1.4.4-7.el6.x86_64
Comment 2 Marcela Mašláňová 2013-08-30 04:18:35 EDT

*** This bug has been marked as a duplicate of bug 1002153 ***

Note You need to log in before you can comment on or make changes to this bug.