Bug 1002887 - Installer does not install updates
Installer does not install updates
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 03:23 EDT by Georg Sauthoff
Modified: 2013-08-30 08:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 08:32:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Georg Sauthoff 2013-08-30 03:23:22 EDT
Description of problem:

The graphical Fedora installer asks at the beginning to configure an internet connections. 

I had configured one but I was surprised that a 'yum update' directly after a fresh install installed tons of updates. It seems that during install no updates were fetched at all

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Boot Fedora-19-x86_64-DVD.iso and install it
2. Configure internet connection in the installer
3. execute 'yum update' after the first reboot

Actual results:

Tons of package updates are installed.

Yum even asks for the permission importing a gpg key from 'file:///...' which is completely unnecessary. I mean, I've just installed the distribution after I've verified the sha256 hash of the iso - of course I trust the included GPG key for installing packages from the standard Fedora system repositories!

Expected results:

No updates necessary (because the installer already looked for updates and installed them).

No superfluous interactive yum prompts for default installed gpg keys.

Additional info:
Comment 1 Samantha N. Bueno 2013-08-30 08:32:03 EDT
If you're installing packages from the DVD, you're getting the versions that were incorporated into the DVD image. Many of those packages have seen updates since that media was generated.

Also, the installer does not import GPG keys, that is why you are being prompted to import them when using yum for the first time following installation.

Note You need to log in before you can comment on or make changes to this bug.