Bug 1002907 - changelog binary parser not working
changelog binary parser not working
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 04:26 EDT by Ajeet Jha
Modified: 2016-02-17 19:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-29 05:28:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ajeet Jha 2013-08-30 04:26:52 EDT
Description of problem:
Changelog binary parser failes to parse the brick changelog.

Version-Release number of selected component (if applicable):


How reproducible:
A volume with changelog enabled and encoding set to "binary", and geo-replication
when enabled with a slave volume, replication fails.

Steps to Reproduce:
1. gluster volume set <vol-name>  changelog-enabled
2. gluster volume set <vol-name>  encoding binary
3. gluster volume geo-replication <master-vol> <slave-hostname>::<slave-vol> start

Actual results:
Error : Unable to extract changelog file-name

Expected results:
successful processing of changelog by binary parser

Additional info:
Comment 1 Anand Avati 2013-08-30 05:11:01 EDT
REVIEW: http://review.gluster.org/5738 (features/changelog : fixed changelog binary parser) posted (#1) for review on master by ajeet jha (ajha@redhat.com)
Comment 2 Anand Avati 2013-08-30 07:41:33 EDT
REVIEW: http://review.gluster.org/5738 (features/changelog : fixed changelog binary parser) posted (#2) for review on master by ajeet jha (ajha@redhat.com)
Comment 3 Anand Avati 2013-09-06 07:05:33 EDT
REVIEW: http://review.gluster.org/5738 (features/changelog : fixed changelog binary parser) posted (#3) for review on master by ajeet jha (ajha@redhat.com)
Comment 4 Anand Avati 2013-09-06 09:50:00 EDT
REVIEW: http://review.gluster.org/5843 (features/changelog : fixed changelog binary parser) posted (#1) for review on master by ajeet jha (ajha@redhat.com)
Comment 5 Anand Avati 2013-09-12 05:16:47 EDT
REVIEW: http://review.gluster.org/5843 (features/changelog : fixed changelog binary parser) posted (#2) for review on master by ajeet jha (ajha@redhat.com)
Comment 8 Aravinda VK 2015-04-20 11:42:27 EDT
More work is expected in Rebase, Parser changes. Moving this back to ASSIGNED.
Comment 9 Aravinda VK 2015-12-29 05:28:43 EST
Not working on Changing Changelog format to binary. Closing this bug since not relevant now. Please reopen this bug if found again.

Note You need to log in before you can comment on or make changes to this bug.