Bug 1003001 - Expired session login pop-up missing organisation links in SAM 1.3 Snapshot #4
Expired session login pop-up missing organisation links in SAM 1.3 Snapshot #4
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 08:53 EDT by mkovacik
Modified: 2014-09-18 13:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing org selection links in re-log-in pop-up window (202.38 KB, image/png)
2013-08-30 08:53 EDT, mkovacik
no flags Details

  None (edit)
Description mkovacik 2013-08-30 08:53:05 EDT
Created attachment 792171 [details]
missing org selection links in re-log-in pop-up window

Description of problem:
In an expired session, a pop-up window is opened for the user to log-in again. However, the links of organisations to select are missing in the pop-up window --- see attached screenshot

Version-Release number of selected component (if applicable):
SAM 1.3 Snapshot #4

How reproducible:
1/1 so far

Steps to Reproduce:
1. log in 
2. navigate some page e.g. Administration -> Reports
3. wait till the session expires
4. re-log-in from the pop-up window
5. missing links to repositories are shown

Actual results:
re-login pop-up window misses the organisation links to select
can't navigate away from the pop-up
refresh of page is a workaround

Expected results:
organisation selection links not required to precede from the re-log-in pop-up window or the pop-up window shows them properly 

Additional info:
See attached screenshot
Comment 1 Tom McKay 2013-08-30 09:38:04 EDT
This is a known issue in katello: When the session expires, the next call made by the client redirects to the login page, even if that call is an ajax call.

As you can see, the "login" is nested within the right hand portion of the page, rather than filling the entire page. 

The work-around, when this state is encountered, is to refresh the page so the proper login appears.

Moving this to Sat6 product for consideration in shared product code.
Comment 3 Mike McCune 2014-03-18 13:37:45 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.