Bug 1003055 - the log should mention when there is a group upgrade
the log should mention when there is a group upgrade
Status: NEW
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 12:01 EDT by Kamil Páral
Modified: 2015-01-13 10:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-08-30 12:01:00 EDT
Description of problem:

This is my today's system update:

# yum update
Loaded plugins: changelog, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package autocorr-cs.noarch 1:4.1.0.4-6.fc19 will be updated
---> Package autocorr-cs.noarch 1:4.1.1.2-2.fc19 will be an update
---> Package autocorr-en.noarch 1:4.1.0.4-6.fc19 will be updated
---> Package autocorr-en.noarch 1:4.1.1.2-2.fc19 will be an update
---> Package fakeroot.x86_64 0:1.18.4-1.fc19 will be updated
---> Package fakeroot.x86_64 0:1.18.4-2.fc19 will be an update
---> Package fakeroot-libs.x86_64 0:1.18.4-1.fc19 will be updated
---> Package fakeroot-libs.x86_64 0:1.18.4-2.fc19 will be an update
---> Package fedpkg.noarch 0:1.13-1.fc19 will be updated
---> Package fedpkg.noarch 0:1.14-1.fc19 will be an update
---> Package firefox.x86_64 0:23.0-1.fc19 will be updated
---> Package firefox.x86_64 0:23.0.1-1.fc19 will be an update
---> Package gdb.x86_64 0:7.6-34.fc19 will be updated
---> Package gdb.x86_64 0:7.6-35.fc19 will be an update
---> Package glibc.x86_64 0:2.17-13.fc19 will be updated
---> Package glibc.x86_64 0:2.17-14.fc19 will be an update
---> Package glibc-common.x86_64 0:2.17-13.fc19 will be updated
---> Package glibc-common.x86_64 0:2.17-14.fc19 will be an update
---> Package google-noto-sans-lisu-fonts.noarch 0:20130807-1.fc19 will be installed
---> Package google-noto-sans-mandaic-fonts.noarch 0:20130807-1.fc19 will be installed
---> Package google-noto-sans-meeteimayek-fonts.noarch 0:20130807-1.fc19 will be installed
---> Package google-noto-sans-tagalog-fonts.noarch 0:20130807-1.fc19 will be installed
---> Package google-noto-sans-tai-tham-fonts.noarch 0:20130807-1.fc19 will be installed
---> Package google-noto-sans-tai-viet-fonts.noarch 0:20130807-1.fc19 will be installed
---> Package kbd.x86_64 0:1.15.5-6.fc19 will be updated
---> Package kbd.x86_64 0:1.15.5-7.fc19 will be an update
---> Package kbd-misc.noarch 0:1.15.5-6.fc19 will be updated
---> Package kbd-misc.noarch 0:1.15.5-7.fc19 will be an update
---> Package leveldb.x86_64 0:1.12.0-3.fc19 will be updated
---> Package leveldb.x86_64 0:1.12.0-5.fc19 will be an update
---> Package liberation-fonts-common.noarch 1:1.07.3-1.fc19 will be updated
---> Package liberation-fonts-common.noarch 1:1.07.3-2.fc19 will be an update
---> Package liberation-mono-fonts.noarch 1:1.07.3-1.fc19 will be updated
---> Package liberation-mono-fonts.noarch 1:1.07.3-2.fc19 will be an update
---> Package liberation-sans-fonts.noarch 1:1.07.3-1.fc19 will be updated
---> Package liberation-sans-fonts.noarch 1:1.07.3-2.fc19 will be an update
---> Package liberation-serif-fonts.noarch 1:1.07.3-1.fc19 will be updated
---> Package liberation-serif-fonts.noarch 1:1.07.3-2.fc19 will be an update
---> Package libntlm.x86_64 0:1.3-4.fc19 will be updated
---> Package libntlm.x86_64 0:1.4-1.fc19 will be an update
---> Package libreoffice-calc.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-calc.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-core.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-core.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-draw.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-draw.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-graphicfilter.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-graphicfilter.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-impress.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-impress.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-langpack-cs.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-langpack-cs.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-langpack-en.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-langpack-en.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-math.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-math.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-opensymbol-fonts.noarch 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-opensymbol-fonts.noarch 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-pdfimport.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-pdfimport.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-pyuno.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-pyuno.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-ure.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-ure.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-writer.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-writer.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package libreoffice-xsltfilter.x86_64 1:4.1.0.4-6.fc19 will be updated
---> Package libreoffice-xsltfilter.x86_64 1:4.1.1.2-2.fc19 will be an update
---> Package lockdev.x86_64 0:1.0.4-0.8.20111007git.fc19 will be updated
---> Package lockdev.x86_64 0:1.0.4-0.11.20111007git.fc19 will be an update
---> Package numpy.x86_64 1:1.7.1-2.fc19 will be updated
---> Package numpy.x86_64 1:1.7.1-5.fc19 will be an update
---> Package python-pillow.x86_64 0:2.0.0-10.gitd1c6db8.fc19 will be updated
---> Package python-pillow.x86_64 0:2.0.0-11.gitd1c6db8.fc19 will be an update
---> Package python-requests.noarch 0:1.2.3-3.fc19 will be updated
---> Package python-requests.noarch 0:1.2.3-5.fc19 will be an update
---> Package python-urllib3.noarch 0:1.7-1.fc19 will be updated
---> Package python-urllib3.noarch 0:1.7-3.fc19 will be an update
---> Package satyr.x86_64 0:0.5-2.fc19 will be updated
---> Package satyr.x86_64 0:0.7-1.fc19 will be an update
---> Package tig.x86_64 0:1.2-1.fc19 will be updated
---> Package tig.x86_64 0:1.2.1-1.fc19 will be an update
---> Package uniconvertor.x86_64 0:1.1.4-7.fc19 will be updated
---> Package uniconvertor.x86_64 0:2.0-0.1.svn340.fc19 will be an update
---> Package usb_modeswitch.x86_64 0:1.2.6-1.fc19 will be updated
---> Package usb_modeswitch.x86_64 0:1.2.7-3.fc19 will be an update
---> Package xulrunner.x86_64 0:23.0-2.fc19 will be updated
---> Package xulrunner.x86_64 0:23.0.1-1.fc19 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies

Dependencies Resolved

========================================================================================
 Package                         Arch   Version                   Repository       Size
========================================================================================
Installing:
 google-noto-sans-lisu-fonts     noarch 20130807-1.fc19           updates-testing  13 k
 google-noto-sans-mandaic-fonts  noarch 20130807-1.fc19           updates-testing  17 k
 google-noto-sans-meeteimayek-fonts
                                 noarch 20130807-1.fc19           updates-testing  19 k
 google-noto-sans-tagalog-fonts  noarch 20130807-1.fc19           updates-testing  13 k
 google-noto-sans-tai-tham-fonts noarch 20130807-1.fc19           updates-testing  34 k
 google-noto-sans-tai-viet-fonts noarch 20130807-1.fc19           updates-testing  19 k
Updating:
 autocorr-en                     noarch 1:4.1.1.2-2.fc19          updates         153 k
 fakeroot                        x86_64 1.18.4-2.fc19             updates          82 k
 fakeroot-libs                   x86_64 1.18.4-2.fc19             updates          23 k
 fedpkg                          noarch 1.14-1.fc19               updates          40 k
 firefox                         x86_64 23.0.1-1.fc19             updates-testing  27 M
 gdb                             x86_64 7.6-35.fc19               updates-testing 2.1 M
 glibc                           x86_64 2.17-14.fc19              updates         3.6 M
 glibc-common                    x86_64 2.17-14.fc19              updates          11 M
 kbd                             x86_64 1.15.5-7.fc19             updates-testing 345 k
 kbd-misc                        noarch 1.15.5-7.fc19             updates-testing 2.1 M
 leveldb                         x86_64 1.12.0-5.fc19             updates         158 k
 liberation-fonts-common         noarch 1:1.07.3-2.fc19           updates-testing  27 k
 liberation-mono-fonts           noarch 1:1.07.3-2.fc19           updates-testing 228 k
 liberation-sans-fonts           noarch 1:1.07.3-2.fc19           updates-testing 279 k
 liberation-serif-fonts          noarch 1:1.07.3-2.fc19           updates-testing 299 k
 libntlm                         x86_64 1.4-1.fc19                updates-testing  50 k
 libreoffice-calc                x86_64 1:4.1.1.2-2.fc19          updates         7.5 M
 libreoffice-core                x86_64 1:4.1.1.2-2.fc19          updates          80 M
 libreoffice-draw                x86_64 1:4.1.1.2-2.fc19          updates         651 k
 libreoffice-graphicfilter       x86_64 1:4.1.1.2-2.fc19          updates         411 k
 libreoffice-impress             x86_64 1:4.1.1.2-2.fc19          updates         1.1 M
 libreoffice-langpack-cs         x86_64 1:4.1.1.2-2.fc19          updates         6.7 M
 libreoffice-langpack-en         x86_64 1:4.1.1.2-2.fc19          updates          43 k
 libreoffice-math                x86_64 1:4.1.1.2-2.fc19          updates         991 k
 libreoffice-opensymbol-fonts    noarch 1:4.1.1.2-2.fc19          updates         191 k
 libreoffice-pdfimport           x86_64 1:4.1.1.2-2.fc19          updates         270 k
 libreoffice-pyuno               x86_64 1:4.1.1.2-2.fc19          updates         607 k
 libreoffice-ure                 x86_64 1:4.1.1.2-2.fc19          updates         2.6 M
 libreoffice-writer              x86_64 1:4.1.1.2-2.fc19          updates         4.3 M
 libreoffice-xsltfilter          x86_64 1:4.1.1.2-2.fc19          updates         230 k
 lockdev                         x86_64 1.0.4-0.11.20111007git.fc19
                                                                  updates-testing  31 k
 numpy                           x86_64 1:1.7.1-5.fc19            updates-testing 2.8 M
 python-pillow                   x86_64 2.0.0-11.gitd1c6db8.fc19  updates-testing 439 k
 python-requests                 noarch 1.2.3-5.fc19              updates-testing  75 k
 python-urllib3                  noarch 1.7-3.fc19                updates-testing  60 k
 satyr                           x86_64 0.7-1.fc19                updates-testing 481 k
 tig                             x86_64 1.2.1-1.fc19              updates-testing 134 k
 uniconvertor                    x86_64 2.0-0.1.svn340.fc19       updates-testing 1.5 M
 usb_modeswitch                  x86_64 1.2.7-3.fc19              updates-testing 158 k
 xulrunner                       x86_64 23.0.1-1.fc19             updates-testing  21 M
Updating for dependencies:
 autocorr-cs                     noarch 1:4.1.1.2-2.fc19          updates         136 k

Transaction Summary
========================================================================================
Install   6 Packages
Upgrade  40 Packages (+1 Dependent package)

Total size: 180 M
Total download size: 176 M
Is this ok [y/d/N]: 


There are some google-noto-* packages which are marked as Installing, but in the log there's no hint as what package requires them. After consulting with geppetto in #yum, I learned that this is a group upgrade.

Could we please make the log clearer, so that people are not confused why those packages are being installed? Something like this:

> ---> Group foobar has been updated, installing new packages:
> -----> Package xyz will be installed
> -----> Package abc will be installed

Thanks!


Version-Release number of selected component (if applicable):
yum-3.4.3-106.fc19.noarch
Comment 1 Kamil Páral 2013-08-30 12:03:08 EDT
Oh that lovely lovely 80-chars line wrapping. The log is also available here:
http://paste.fedoraproject.org/36082/
Comment 2 Fedora End Of Life 2015-01-09 14:39:37 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Note You need to log in before you can comment on or make changes to this bug.