Bug 1003091 - Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 14:23 EDT by Dean Hunter
Modified: 2014-01-01 13:19 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 13:19:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dean Hunter 2013-08-30 14:23:13 EDT
Description of problem:

Something in the last two weeks of updates is changing the symbolic links in /etc/pki/rpm-gpg.  I had not updated my local repositories for two weeks and now I can no longer perform installation tasks that completed successfully previously.  What have I done wrong?


Version-Release number of selected component (if applicable):


How reproducible: Consistent


Steps to Reproduce:

1. Build a new VM using the DVD ISO and local repositories

2. Try to install additional software


Actual results:

....
Total download size: 5.1 M
Installed size: 23 M
Downloading packages:
warning: /var/cache/yum/x86_64/19/local-updates/packages/autofs-5.0.7-28.fc19.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fb4b18e6: NOKEY
Public key for autofs-5.0.7-28.fc19.x86_64.rpm is not installed
Public key for certmonger-0.67-1.fc19.x86_64.rpm is not installed
--------------------------------------------------------------------------------
Total                                           8.5 MB/s | 5.1 MB     00:00     
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64


GPG key retrieval failed: [Errno 14] curl#37 - "Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64"
....


Expected results:

Successful installation


Additional info:

This is from a physical server that I updated about 10:30 last night.  I notice that all of the architecture specific symbolic links were changed and now have the Fedora version number in the name.

[root@host ~]# ls -l /etc/pki/rpm-gpg
total 16
lrwxrwxrwx. 1 root root   29 Aug 29 22:38 RPM-GPG-KEY-19-fedora -> RPM-GPG-KEY-fedora-19-primary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-aarch64 -> RPM-GPG-KEY-fedora-19-secondary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-arm -> RPM-GPG-KEY-fedora-19-secondary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-armhfp -> RPM-GPG-KEY-fedora-19-secondary
lrwxrwxrwx. 1 root root   29 Aug 29 22:38 RPM-GPG-KEY-fedora-19-i386 -> RPM-GPG-KEY-fedora-19-primary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-ppc -> RPM-GPG-KEY-fedora-19-secondary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-ppc64 -> RPM-GPG-KEY-fedora-19-secondary
-rw-r--r--. 1 root root 1658 Aug 21 00:28 RPM-GPG-KEY-fedora-19-primary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-s390 -> RPM-GPG-KEY-fedora-19-secondary
lrwxrwxrwx. 1 root root   31 Aug 29 22:38 RPM-GPG-KEY-fedora-19-s390x -> RPM-GPG-KEY-fedora-19-secondary
-rw-r--r--. 1 root root 3819 Aug 21 00:28 RPM-GPG-KEY-fedora-19-secondary
lrwxrwxrwx. 1 root root   29 Aug 29 22:38 RPM-GPG-KEY-fedora-19-x86_64 -> RPM-GPG-KEY-fedora-19-primary
-rw-r--r--. 1 root root 1658 Aug 21 00:28 RPM-GPG-KEY-fedora-20-primary
-rw-r--r--. 1 root root 3819 Aug 21 00:28 RPM-GPG-KEY-fedora-20-secondary

[root@host ~]#
Comment 1 Dean Hunter 2013-08-30 20:14:30 EDT
Adding:

  ln -s /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-19-primary \\
        /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64          # RedHat bug 1003091

to the Anaconda Kickstart post script resolves the problem.
Comment 2 Matthew Woehlke 2013-11-13 13:34:05 EST
Additional information: It looks like the default repository configurations have the correct (new style, with version) key name. I'm just now going through and cleaning up my .rpmnew's and noticed that my repo configurations had such, so that the old repo configs with the old name are used. So probably this only affects people that have modified their repo configs and get .rpmnew's of them as a result.
Comment 3 Zdeněk Pavlas 2013-11-14 04:03:03 EST
Maybe fedora-release should provide both symlink variants during a transition period?  Having a proper 3-way merge in rpm would help, too.
Comment 4 Truong Anh Tuan 2013-12-09 11:07:42 EST
I got this error message too.
And I simply remove the file /etc/yum.repos.d/fedora-updates-testing.repo and rename /etc/yum.repos.d/fedora-updates-testing.repo.rpmnew file back to replace it.

It works fine now.
Comment 5 Per Arnold Blåsmo 2013-12-19 08:41:32 EST
(In reply to Truong Anh Tuan from comment #4)
> I got this error message too.
> And I simply remove the file /etc/yum.repos.d/fedora-updates-testing.repo
> and rename /etc/yum.repos.d/fedora-updates-testing.repo.rpmnew file back to
> replace it.
> 
> It works fine now.

I had the same problem, but it was the fedora-updates.repo that had a rpmnew file. 

Replacing the fedora-updates.repo with the rpmnew file fixed it.
Comment 6 Germano Massullo 2013-12-30 04:20:16 EST
Confirming on Fedora 20



# ls -l /etc/pki/rpm-gpg
totale 52
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-20-fedora -> RPM-GPG-KEY-fedora-20-primary
-rw-r--r--. 1 root root 1726  1 mar  2007 RPM-GPG-KEY-adobe-linux
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-20-aarch64 -> RPM-GPG-KEY-fedora-20-secondary
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-fedora-20-armhfp -> RPM-GPG-KEY-fedora-20-primary
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-fedora-20-i386 -> RPM-GPG-KEY-fedora-20-primary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-20-ppc -> RPM-GPG-KEY-fedora-20-secondary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-20-ppc64 -> RPM-GPG-KEY-fedora-20-secondary
-rw-r--r--. 1 root root 1658 27 nov 14.31 RPM-GPG-KEY-fedora-20-primary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-20-s390 -> RPM-GPG-KEY-fedora-20-secondary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-20-s390x -> RPM-GPG-KEY-fedora-20-secondary
-rw-r--r--. 1 root root 3819 27 nov 14.31 RPM-GPG-KEY-fedora-20-secondary
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-fedora-20-x86_64 -> RPM-GPG-KEY-fedora-20-primary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-21-aarch64 -> RPM-GPG-KEY-fedora-21-secondary
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-fedora-21-armhfp -> RPM-GPG-KEY-fedora-21-primary
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-fedora-21-i386 -> RPM-GPG-KEY-fedora-21-primary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-21-ppc -> RPM-GPG-KEY-fedora-21-secondary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-21-ppc64 -> RPM-GPG-KEY-fedora-21-secondary
-rw-r--r--. 1 root root 1658 27 nov 14.31 RPM-GPG-KEY-fedora-21-primary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-21-s390 -> RPM-GPG-KEY-fedora-21-secondary
lrwxrwxrwx. 1 root root   31 18 dic 14.00 RPM-GPG-KEY-fedora-21-s390x -> RPM-GPG-KEY-fedora-21-secondary
-rw-r--r--. 1 root root 3819 27 nov 14.31 RPM-GPG-KEY-fedora-21-secondary
lrwxrwxrwx. 1 root root   29 18 dic 14.00 RPM-GPG-KEY-fedora-21-x86_64 -> RPM-GPG-KEY-fedora-21-primary
-rw-r--r--. 1 root root 1694  6 nov  2008 RPM-GPG-KEY-fedora-ia64
lrwxrwxrwx. 1 root root   44 18 dic 14.02 RPM-GPG-KEY-rpmfusion-free-fedora -> RPM-GPG-KEY-rpmfusion-free-fedora-20-primary
lrwxrwxrwx. 1 root root   44 18 dic 14.02 RPM-GPG-KEY-rpmfusion-free-fedora-20 -> RPM-GPG-KEY-rpmfusion-free-fedora-20-primary
-rw-r--r--. 1 root root 1719  1 gen  2013 RPM-GPG-KEY-rpmfusion-free-fedora-20-primary
lrwxrwxrwx. 1 root root   44 18 dic 14.02 RPM-GPG-KEY-rpmfusion-free-fedora-21 -> RPM-GPG-KEY-rpmfusion-free-fedora-21-primary
-rw-r--r--. 1 root root 1719 28 giu  2013 RPM-GPG-KEY-rpmfusion-free-fedora-21-primary
lrwxrwxrwx. 1 root root   44 18 dic 14.02 RPM-GPG-KEY-rpmfusion-free-fedora-22 -> RPM-GPG-KEY-rpmfusion-free-fedora-22-primary
-rw-r--r--. 1 root root 1719 15 dic 23.48 RPM-GPG-KEY-rpmfusion-free-fedora-22-primary
lrwxrwxrwx. 1 root root   44 18 dic 14.02 RPM-GPG-KEY-rpmfusion-free-fedora-latest -> RPM-GPG-KEY-rpmfusion-free-fedora-21-primary
lrwxrwxrwx. 1 root root   44 18 dic 14.02 RPM-GPG-KEY-rpmfusion-free-fedora-rawhide -> RPM-GPG-KEY-rpmfusion-free-fedora-22-primary
lrwxrwxrwx. 1 root root   47 18 dic 14.12 RPM-GPG-KEY-rpmfusion-nonfree-fedora -> RPM-GPG-KEY-rpmfusion-nonfree-fedora-20-primary
lrwxrwxrwx. 1 root root   47 18 dic 14.12 RPM-GPG-KEY-rpmfusion-nonfree-fedora-20 -> RPM-GPG-KEY-rpmfusion-nonfree-fedora-20-primary
-rw-r--r--. 1 root root 1723  1 gen  2013 RPM-GPG-KEY-rpmfusion-nonfree-fedora-20-primary
lrwxrwxrwx. 1 root root   47 18 dic 14.12 RPM-GPG-KEY-rpmfusion-nonfree-fedora-21 -> RPM-GPG-KEY-rpmfusion-nonfree-fedora-21-primary
-rw-r--r--. 1 root root 1723 28 giu  2013 RPM-GPG-KEY-rpmfusion-nonfree-fedora-21-primary
lrwxrwxrwx. 1 root root   47 18 dic 14.12 RPM-GPG-KEY-rpmfusion-nonfree-fedora-22 -> RPM-GPG-KEY-rpmfusion-nonfree-fedora-22-primary
-rw-r--r--. 1 root root 1723 15 dic 23.52 RPM-GPG-KEY-rpmfusion-nonfree-fedora-22-primary
lrwxrwxrwx. 1 root root   47 18 dic 14.12 RPM-GPG-KEY-rpmfusion-nonfree-fedora-latest -> RPM-GPG-KEY-rpmfusion-nonfree-fedora-21-primary
lrwxrwxrwx. 1 root root   47 18 dic 14.12 RPM-GPG-KEY-rpmfusion-nonfree-fedora-rawhide -> RPM-GPG-KEY-rpmfusion-nonfree-fedora-22-primary
Comment 7 Dennis Gilmore 2014-01-01 13:19:27 EST
this only happens if you have modified your repo files. the fix is to manually replace the .repo files with the .rpmnew copies. we really can not do anything else.

Note You need to log in before you can comment on or make changes to this bug.