Bug 1003120 - Add support for GRE networks
Add support for GRE networks
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: beta
: 4.0
Assigned To: Terry Wilson
Nir Magnezi
:
Depends On:
Blocks: 1004397
  Show dependency treegraph
 
Reported: 2013-08-30 17:47 EDT by Terry Wilson
Modified: 2013-12-19 19:22 EST (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.5.dev740.el6ost
Doc Type: Enhancement
Doc Text:
Feature: Add support for GRE networks.
Story Points: ---
Clone Of:
: 1004397 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:22:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Wilson 2013-08-30 17:47:10 EDT
Packstack currently doesn't support setting up GRE networks. Since OVS GRE-supported kernels are now available, support for them should be added to packstack.
Comment 2 Terry Wilson 2013-09-04 10:13:03 EDT
To test,

packstack --allinone --quantum-ovs-tunnel-ranges=1:1000 --quantum-ovs-tenant-network-type=gre

or, make sure that the answer file contains
CONFIG_QUANTUM_OVS_TUNNEL_RANGES=1:1000
CONFIG_QUANTUM_OVS_TENANT_NETWORK_TYPE=gre

s/quantum/neutron/ for havana.
Comment 3 Nir Magnezi 2013-10-21 05:28:50 EDT
Verified NVR: openstack-packstack-2013.2.1-0.6.dev763.el6ost.noarch

Installed OpenStack via packstack as follows:
# packstack --allinone --neutron-ovs-tunnel-ranges=1:1000 --neutron-ovs-tenant-network-type=gre -d

Result:
=======
1. snipped from /etc/neutron/plugin.ini

[OVS]
local_ip=<IP>
tunnel_id_ranges=1:1000
tunnel_bridge=br-tun
integration_bridge=br-int
enable_tunneling=True
tenant_network_type=gre

2. Networking team tested and confirmed that GRE tunneling works properly.
Comment 5 errata-xmlrpc 2013-12-19 19:22:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.