Bug 1003142 - SELinux is preventing /usr/bin/gnome-session from connectto access on the unix_stream_socket /run/systemd/journal/stdout
SELinux is preventing /usr/bin/gnome-session from connectto access on the uni...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-30 23:51 EDT by Larry O'Leary
Modified: 2013-09-11 21:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-74.2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 21:53:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry O'Leary 2013-08-30 23:51:02 EDT
Description of problem:
SELinux is preventing /usr/bin/gnome-session from connectto access on the unix_stream_socket /run/systemd/journal/stdout.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gnome-session should be allowed connectto access on the stdout unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-session /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp


Additional Information:
Source Context                xguest_u:xguest_r:xguest_t:s0
Target Context                system_u:system_r:kernel_t:s0
Target Objects                /run/systemd/journal/stdout [ unix_stream_socket ]
Source                        gnome-session
Source Path                   /usr/bin/gnome-session
Port                          <Unknown>
Host                          home02
Source RPM Packages           gnome-session-3.8.4-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-73.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     home02
Platform                      Linux home02 3.10.9-200.fc19.x86_64 #1
                              SMP Wed Aug 21 19:27:58 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-08-28 21:26:48 CDT
Last Seen                     2013-08-30 22:19:37 CDT
Local ID                      8626186e-5ada-4d01-8391-2ef177a5f030

Raw Audit Messages
type=AVC msg=audit(1377919177.330:897): avc:  denied  { connectto } for  pid=9544 comm="gnome-session" path="/run/systemd/journal/stdout" scontext=xguest_u:xguest_r:xguest_t:s0 tcontext=system_u:system_r:kernel_t:s0 tclass=unix_stream_socket


type=SYSCALL msg=audit(1377919177.330:897): arch=x86_64 syscall=connect success=no exit=EACCES a0=7 a1=7fff4f712280 a2=1d a3=7 items=0 ppid=9508 pid=9544 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=43 tty=(none) comm=gnome-session exe=/usr/bin/gnome-session subj=xguest_u:xguest_r:xguest_t:s0 key=(null)

Hash: gnome-session,xguest_t,kernel_t,unix_stream_socket,connectto
Comment 1 Larry O'Leary 2013-08-30 23:53:37 EDT
This looks like the same issue that was fixed in release 3.12.1-71.fc19 (Bug 995394). Is this a regression?
Comment 2 Daniel Walsh 2013-09-04 13:29:23 EDT
e4393ced041832eaabea0dc2dc8f41ef1fad408c fixes this for less priv users.
Comment 3 Miroslav Grepl 2013-09-05 04:13:24 EDT
Has been added.
Comment 4 Fedora Update System 2013-09-09 03:53:46 EDT
selinux-policy-3.12.1-74.2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-74.2.fc19
Comment 5 Fedora Update System 2013-09-09 19:56:56 EDT
Package selinux-policy-3.12.1-74.2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-74.2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-16231/selinux-policy-3.12.1-74.2.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-09-11 21:53:10 EDT
selinux-policy-3.12.1-74.2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.