Bug 1003159 - SELinux is preventing /usr/lib64/xulrunner/plugin-container from using the 'transition' accesses on a process.
SELinux is preventing /usr/lib64/xulrunner/plugin-container from using the 't...
Status: CLOSED DUPLICATE of bug 885834
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6aff9b4e02a24811276521b1c2a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 06:12 EDT by Giacomo Mattiuzzi
Modified: 2013-09-03 06:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 06:02:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giacomo Mattiuzzi 2013-08-31 06:12:37 EDT
Description of problem:
SELinux is preventing /usr/lib64/xulrunner/plugin-container from using the 'transition' accesses on a process.

*****  Plugin mozplugger (99.1 confidence) suggests  *************************

If usare il pacchetto plugin
Then disabilitare i controlli SELinux sui plugin di Firefox.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.81 confidence) suggests  ***************************

If si crede che plugin-container dovrebbe avere possibilità di accesso transition ai processi etichettati mozilla_plugin_t in modo predefinito.
Then si dovrebbe riportare il problema come bug.
E' possibile generare un modulo di politica locale per consentire questo accesso.
Do
consentire questo accesso per il momento eseguendo:
# grep plugin-containe /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:system_r:mozilla_plugin_t:s0-s0:c0.c1
                              023
Target Objects                /usr/bin/pulseaudio [ process ]
Source                        plugin-containe
Source Path                   /usr/lib64/xulrunner/plugin-container
Port                          <Sconosciuto>
Host                          (removed)
Source RPM Packages           xulrunner-22.0-4.fc19.x86_64
Target RPM Packages           pulseaudio-3.0-10.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-300.fc19.x86_64 #1 SMP Tue
                              Jul 30 11:29:05 UTC 2013 x86_64 x86_64
Alert Count                   6
First Seen                    2013-08-05 18:43:38 CEST
Last Seen                     2013-08-14 14:46:16 CEST
Local ID                      36e2ddc8-721a-4d51-9f89-019118d26e88

Raw Audit Messages
type=AVC msg=audit(1376484376.402:516): avc:  denied  { transition } for  pid=4642 comm="plugin-containe" path="/usr/bin/pulseaudio" dev="sdc6" ino=533316 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:system_r:mozilla_plugin_t:s0-s0:c0.c1023 tclass=process


type=SYSCALL msg=audit(1376484376.402:516): arch=x86_64 syscall=execve success=no exit=EACCES a0=7f7fe383cb00 a1=7fffd4a6d610 a2=7f7ff2076c00 a3=7f7fe383c040 items=0 ppid=4405 pid=4642 auid=1000 uid=1002 gid=1002 euid=1002 suid=1002 fsuid=1002 egid=1002 sgid=1002 fsgid=1002 ses=1 tty=(none) comm=plugin-containe exe=/usr/lib64/xulrunner/plugin-container subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-containe,mozilla_plugin_t,mozilla_plugin_t,process,transition

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.4-300.fc19.x86_64
type:           libreport

Potential duplicate: bug 885834
Comment 1 Miroslav Grepl 2013-09-03 06:02:15 EDT

*** This bug has been marked as a duplicate of bug 885834 ***

Note You need to log in before you can comment on or make changes to this bug.