Bug 1003213 - mount local ntfs partition always fails
mount local ntfs partition always fails
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: ntfs-3g (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-31 18:10 EDT by mordred
Modified: 2013-09-03 09:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 09:36:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mordred 2013-08-31 18:10:22 EDT
Description of problem:
ntfs partitions on the system disk displayed on the desktop will not mount.

the error message displayed when this happens is always the following, except for the name of the partition, the device path and username (here "hpc", /dev/sda4, nim):

failed to mount "hpc"

error mounting /dev/sda4 at /run/media/nim/hpc
command line: mount -t ntfs -o "uhelper=udisk2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177"
/dev/sda4 /run/media/nim/hpc exited with non-zero exit status 14.
the disk contains an unclean file system (0,0)
metadata kept in windows cache, refused to mount.
failed to mount /dev/sda4, operation not permitted.
the NTFS partition is in an unsafe state. please resume and shutdown 
Windows fully (no hibernation or fast restarting) or mount the volume
read-only with the 'ro' mount option.

note: the Windows system on the disk was fully shutdown.

note: local ntfs partitions will mount in read-only mode from the command line to designated mount point.

note: removable drives mount from their desktop menus without error.
Version-Release number of selected component (if applicable):


How reproducible:
use a machine dual-booting Windows, Fedora.
ensure Windows is fully shut-down.

Steps to Reproduce:
1. in Fedora, right-click to get the desktop menu for the ntfs partition.
2. choose mount.

Actual results:
see above.

Expected results:
mounted ntfs partition, no errors.

Additional info:
Comment 1 Kevin Fenzi 2013-09-01 12:08:27 EDT
Moving over to the ntfs-3g package for comment.
Comment 2 Jean-Pierre André 2013-09-01 15:27:46 EDT
"the Windows system on the disk was fully shutdown"

But Windows 8 has its own definition of "fully shutdown", see http://jp-andre.pagesperso-orange.fr/advanced-ntfs-3g.html#windows8
Comment 3 mordred 2013-09-02 13:36:21 EDT
methods on this page:

http://jp-andre.pagesperso-orange.fr/advanced-ntfs-3g.html#windows8

solve the issue.
Comment 4 Tom "spot" Callaway 2013-09-03 09:36:31 EDT
Since the "bug" is in Windows 8, closing this as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.