Bug 1003234 - password.py: Using "set_admin_password" to change admin password failed in single mode
password.py: Using "set_admin_password" to change admin password failed in si...
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Douglas Schilling Landgraf
Petr Kubica
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 03:57 EDT by haiyang,dong
Modified: 2016-02-10 14:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-17 08:31:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot (8.36 KB, image/png)
2013-09-01 03:57 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-09-01 03:57:54 EDT
Created attachment 792528 [details]
attached Screenshot

Description of problem:
password.py: Using "set_admin_password" to change admin password failed with the follow info in single mode:
[ERROR] /config is not mounted(Seen set_admin_password.png)

No this issue in rescue mode : Using "set_admin_password" to change admin password success in rescue mode

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.999.20130830222205git32d308e.480.fc18.iso

How reproducible:
100% 
 
Steps to Reproduce:

Actual result:


Expect result:


Additional info:

--
Comment 1 Sandro Bonazzola 2014-03-04 04:29:58 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 2 Sandro Bonazzola 2014-05-08 09:56:26 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 3 Douglas Schilling Landgraf 2014-09-04 08:58:51 EDT
(In reply to haiyang,dong from comment #0)
> Created attachment 792528 [details]
> attached Screenshot
> 
> Description of problem:
> password.py: Using "set_admin_password" to change admin password failed with
> the follow info in single mode:
> [ERROR] /config is not mounted(Seen set_admin_password.png)
> 
> No this issue in rescue mode : Using "set_admin_password" to change admin
> password success in rescue mode
> 
> Version-Release number of selected component (if applicable):
> ovirt-node-iso-3.1.0-0.999.999.20130830222205git32d308e.480.fc18.iso
> 
> How reproducible:
> 100% 
>  
> Steps to Reproduce:
> 
> Actual result:
> 
> 
> Expect result:
> 
> 
> Additional info:
> 
> --
Hi hadong,

I can't reproduce this report in the current upstream. I am moving to ON_QA for double check before I close it.

Basically my steps for validation:
- Boot as single
- /usr/libexec/ovirt-config-password
  > admin (set the new password)
- reboot and test in a non single mode.


Thanks!
Comment 4 Petr Kubica 2014-09-15 09:23:10 EDT
Verified in oVirt Node Hypervisor release 3.1.0_master (20140805.0)
Comment 5 Sandro Bonazzola 2014-10-17 08:31:44 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.