Bug 1003297 - Wine couldn't display content of chm help file
Wine couldn't display content of chm help file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 15:25 EDT by Mikhail
Modified: 2013-09-03 23:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 23:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of hh.exe (28.54 KB, image/png)
2013-09-01 15:25 EDT, Mikhail
no flags Details
example chm file (3.92 MB, application/vnd.ms-htmlhelp)
2013-09-01 15:28 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2013-09-01 15:25:07 EDT
Created attachment 792648 [details]
screenshot of hh.exe

Description of problem:
Wine couldn't display content of chm help file

$ wine --version
wine-1.7.0
Comment 1 Mikhail 2013-09-01 15:28:25 EDT
Created attachment 792649 [details]
example chm file
Comment 2 Andreas Bierfert 2013-09-01 15:44:37 EDT
Is this new? Or a did this appear in 1.7.0? How about 1.7.1?
Comment 3 Michael Cronenworth 2013-09-01 23:06:12 EDT
The attachment opens without error for me on 1.7.1. I have not tried other versions.
Comment 4 Mikhail 2013-09-03 14:46:36 EDT
$ wine --version
wine-1.7.1

And problem still present.
Comment 5 Michael Cronenworth 2013-09-03 22:33:46 EDT
Did you try a fresh WINEPREFIX?

WINEPREFIX=/home/foo/tmp wine hh help.chm

I have no problem displaying the full file on my system.
Comment 6 Mikhail 2013-09-03 23:38:44 EDT
with fresh WINEPREFIX works for me too. What I need to do for fix it for default WINEPREFIX?
Comment 7 Michael Cronenworth 2013-09-03 23:49:12 EDT
This might have been caused by the wine-gecko gcc bug and your prefix has the old files. Try deleting .wine/drive_c/windows/syswow64/gecko/2.21/ and .wine/drive_c/windows/system32/gecko/2.21/ and .wine/.update-timestamp. Then start wine and it will regenerate and re-copy the gecko files.

Note You need to log in before you can comment on or make changes to this bug.