Bug 1003390 - python-blessings-1.6 is available
python-blessings-1.6 is available
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: python-blessings (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 18:48 EDT by Upstream Release Monitoring
Modified: 2016-08-15 02:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-15 02:36:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-09-01 18:48:48 EDT
Latest upstream release: 1.5.1
Current version/release in Fedora Rawhide: 1.5-3.fc20
URL: https://github.com/erikrose/blessings/tags

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Dan Callaghan 2013-11-28 20:41:44 EST
Not going to bother with 1.5.1 for now, unless there is a particular desire for it. There is only one real bug fix in 1.5.1:
https://github.com/erikrose/blessings/pull/31
Comment 2 Upstream Release Monitoring 2014-10-01 04:30:09 EDT
Latest upstream release: 1.6
Current version/release in Fedora Rawhide: 1.5-5.fc21
URL: https://pypi.python.org/packages/source/b/blessings/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring Soon this service will be implemented by a new system: https://github.com/fedora-infra/anitya/
It will require to manage monitored projects via a new web interface. Please make yourself familiar with the new system to ease the transition.
Comment 3 Dan Callaghan 2014-10-01 18:35:27 EDT
I am going to have to leave this for now because the test suite still fails when stdout is redirected to a log file (as in mock). My original patch to hack around the failures no longer works, there are a bunch of new ones. So this is going to have to wait until I or someone has time to fix the problem properly.

https://github.com/erikrose/blessings/issues/25
Comment 4 Dan Callaghan 2016-08-15 02:36:14 EDT
Upstream seems to be basically dead now... There is an active fork at https://github.com/jquast/blessed/ so I probably need to either retire blessings and package blessed instead, or start going through and backporting all the fixes from blessed...

Regardless this is CLOSED WONTFIX because the issues above are not likely to ever be fixed it seems.

Note You need to log in before you can comment on or make changes to this bug.