Bug 1003409 - xorg-x11-glamor-0.6.0 is available
xorg-x11-glamor-0.6.0 is available
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-glamor (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 19:24 EDT by Upstream Release Monitoring
Modified: 2015-02-13 03:47 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-13 03:47:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2013-09-01 19:24:48 EDT
Latest upstream release: 0.5.1
Current version/release in Fedora Rawhide: 0.5.0-6.20130401git81aadb8.fc20
URL: http://xorg.freedesktop.org/archive/individual/driver/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 1 Upstream Release Monitoring 2014-01-26 08:20:25 EST
Latest upstream release: 0.6.0
Current version/release in Fedora Rawhide: 0.5.1-8.20140117git2ac2fc0d.fc21
URL: http://xorg.freedesktop.org/archive/individual/driver/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at:
https://fedoraproject.org/wiki/Upstream_release_monitoring
Comment 2 Zoltan Boszormenyi 2014-03-23 07:55:24 EDT
Here's a test case that may nudge packagers moving towards a newer Glamor 0.6.x snapshot or Xorg 1.16 built-in glamor.

I use the Fuse emulator and I recently replaced my Radeon HD6570 (EXA driver) with a brand new Radeon R270X, so my system now uses glamor for 2D.

Fuse uses SDL 1.2 for its painting operations.

With the EXA driver, the emulated Sinclair screen was painted instantly.
Under current glamor 0.5.1 snapshot, it's very slow, it looks like a slideshow.
It can be immediately observed by resetting the emulated Sinclair ZX Spectrum 48K.

I took a snapshot of
git://anongit.freedesktop.org/xorg/driver/glamor
and
git://git.freedesktop.org/git/xorg/driver/xf86-video-ati
yesterday (2014-03-22) and compiled them. The glamor code has this backported patchset that was merged into the Xorg xserver 1.16 tree.

After rebooting with the new driver set, the result is almost indistinguishable from the previous EXA speed. 2D games using SDL 1.2 would also greatly benefit from the new glamor code when coupled with Radeon HD7xxx/Rxxx cards.

There is another small but positive change by using these two updated drivers.
Previously (but already using R270X) sometimes a character was rendered as garbage in Firefox, Thunderbird or Libreoffice. Most of the text was correctly rendered except this one character somewhere in the middle.
Highlighting/selecting it fixed it by re-rendering. This occasional garbage was actually quite frequent. With the updated drivers, it is either much less frequent or completely fixed. Anyway, I didn't see badly rendered characters in the last two days after the upgrade.

I tested it with Fedora 21 Rawhide.
Comment 3 Spenk 2014-11-13 17:04:17 EST
Fedora 21 is in beta stage now. And still I'm seeing occasional garbage characters in Firefox, Thunderbird, etc: i.e. white noise / random memory bitmaps.

(I know I bought a cheap, downgraded R7 240 but even that one should be able to do character rendering .. right?)

I installed all relevant packages from fc21 updates-testing. 
Any ideas?
Comment 4 Fedora Admin XMLRPC Client 2015-02-12 13:32:37 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Hans de Goede 2015-02-13 03:47:53 EST
glamor is part of the xserver now, and we're at the latest version there, closing.

Note You need to log in before you can comment on or make changes to this bug.