Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1003442 - [whql][netkvm][wlk]"Ethernet-NDISTest6.0" job always failed on win2k8-32/64
[whql][netkvm][wlk]"Ethernet-NDISTest6.0" job always failed on win2k8-32/64
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On: 1010684 1010687
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-01 23:31 EDT by guo jiang
Modified: 2014-07-11 02:18 EDT (History)
9 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-71
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1010684 1010687 1010688 (view as bug list)
Environment:
Last Closed: 2014-01-01 11:33:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of failed test (96.93 KB, text/html)
2013-09-17 07:42 EDT, Dmitry Fleytman
no flags Details
Patch candidate for 2c_receivepackets failure (967 bytes, patch)
2013-09-22 02:05 EDT, Dmitry Fleytman
no flags Details | Diff

  None (edit)
Description guo jiang 2013-09-01 23:31:37 EDT
Description of problem:
WLK job "Ethernet-NDISTest6.0" always failed on win2k8-32/64

Version-Release number of selected component (if applicable):
   Red Hat Enterprise Linux Server release 6.4 (Santiago)
   kernel-2.6.32-414.el6.x86_64    
   qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64
   virtio-win-prewhql-0.1-67
   spice-server-0.12.4-2.el6.x86_64
   seabios-0.6.1.2-28.el6.x86_64
   vgabios-0.6b-3.7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.Boot guests with CLI:
/usr/libexec/qemu-kvm -M rhel6.5.0 -m 6G -smp 8,cores=8 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2k8-64-nic1.raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:33:21:10:23:42,bus=pci.0,addr=0x4,id=virtio-net-pci0,ctrl_guest_offloads=on -netdev tap,sndbuf=0,id=hostnet1,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet1,mac=00:23:21:10:23:23,bus=pci.0,addr=0x5,id=virtio-net-pci1,ctrl_guest_offloads=on -netdev tap,sndbuf=0,id=hostnet2,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet2,mac=00:13:33:21:a4:20,bus=pci.0,addr=0x6 -uuid e0af0e85-cdc1-486f-b4dd-26c4afbd47e4 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-64-67-nic1,server,nowait -mon chardev=111a,mode=readline -vnc :1 -vga cirrus -name win2k8-64-nic1-67-WLK -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.run "Ethernet-NDISTest6.0" job.

3.

Actual results:
Job "Ethernet-NDISTest6.0" failed with error "Disconnect events 0 should equal connect events 23"


Expected results:
All jobs could be pass without error.

Additional info:
Comment 1 guo jiang 2013-09-01 23:32:20 EDT
Created attachment 792708 [details]
win2k8-32-netkvm-67
Comment 2 guo jiang 2013-09-01 23:33:06 EDT
Created attachment 792709 [details]
win2k8-64-netkvm-67
Comment 4 Yan Vugenfirer 2013-09-15 06:05:26 EDT
Hello,
It looks like incorrect logs were attached (logs for virtio-serial). According to the logs the device is unclassified and there is no NDISTest logs in the CPK.

Please attach the correct ligs.


Best regards,
Yan.
Comment 5 Mike Cao 2013-09-16 04:20:40 EDT
Created attachment 798156 [details]
69-netkvm-win2k8-32
Comment 6 Mike Cao 2013-09-16 04:24:35 EDT
clear needinfo ,referring to (In reply to Yan Vugenfirer from comment #4)
> Hello,
> It looks like incorrect logs were attached (logs for virtio-serial).
> According to the logs the device is unclassified and there is no NDISTest
> logs in the CPK.
> 
> Please attach the correct ligs.
> 
> 
> Best regards,
> Yan.

referring to comment #5
Comment 7 Dmitry Fleytman 2013-09-17 07:40:44 EDT
Failed test is 2c_receivepackets.
Relevant part of logs:

Variation #64 GetEvents
GetEvents
- OpenId = 0x01010001
Received 93 calls to NdisIndicateStatus
Received 93 calls to NdisIndicateStatusComplete
Received 23 NDIS_STATUS_MEDIA_CONNECT status indications
Received 23 NDIS_STATUS_RESET_START status indications
Received 23 NDIS_STATUS_RESET_END status indications
< Resets = 23
< Disconnects = 0
< Connects = 23
FAILED: [21407] Disconnect events 0 should equal connect events 23
Comment 8 Dmitry Fleytman 2013-09-17 07:42:29 EDT
Created attachment 798766 [details]
Log of failed test
Comment 9 Yan Vugenfirer 2013-09-17 08:13:42 EDT
There are also fails in 2c_recvmulticast test - could be related to address change bug.
Comment 10 Dmitry Fleytman 2013-09-18 05:13:34 EDT
I've checked 2c_recvmulticast, it is not related to address change bug. I will investigate what is the problem.
Comment 11 Dmitry Fleytman 2013-09-22 02:05:09 EDT
Created attachment 801097 [details]
Patch candidate for 2c_receivepackets failure
Comment 12 Dmitry Fleytman 2013-09-24 06:34:14 EDT
Fixed by commits listed at BZ#1010684 and BZ#1010687
Comment 13 Mike Cao 2013-10-08 04:02:38 EDT
Verified this issue on virtio-win-prewhql-71&72

Steps:
Run all whql jobs for win2k8-32/64

Actual Results:
All jobs can pass on win2k8-32/64

Based on above ,this issue has been fixed ald ,move status to VERIFIED

Note You need to log in before you can comment on or make changes to this bug.