Bug 1003483 - openstack-packstack: rubygem packages are missing from the repository
openstack-packstack: rubygem packages are missing from the repository
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 03:35 EDT by Yogev Rabl
Modified: 2016-04-26 17:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 14:36:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yogev Rabl 2013-09-02 03:35:51 EDT
Description of problem:
The installation of the openstack with the packstack failes beacaus the rubygems packege is missing from the havana repository. 

Version-Release number of selected component (if applicable):


How reproducible:
install the openstack with the packstack with the version in this repository: http://repos.fedorapeople.org/repos/openstack/openstack-havana/

Steps to Reproduce:
1. Add the repo file to the /etc/yum.repo.d/ directory. 
2. Run an installation of the packstack.
3. 

Actual results:
The installation fails with the error massage that the rubygems are needed as a dependency but aren't available. 

Expected results:
A successful installation. 

Additional info:

ERROR : Error running remote script: package puppet is not installed
Loaded plugins: product-id, rhnplugin, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:3.2.4-1.el6 will be installed
--> Processing Dependency: ruby >= 1.8 for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: facter >= 1.6.11 for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: ruby-rgen >= 0.6.5 for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: ruby >= 1.8.7 for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: ruby-augeas for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: /usr/bin/ruby for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: ruby-shadow for package: puppet-3.2.4-1.el6.noarch
--> Processing Dependency: ruby(selinux) for package: puppet-3.2.4-1.el6.noarch
--> Running transaction check
---> Package facter.x86_64 1:1.7.2-1.el6 will be installed
--> Processing Dependency: ruby(abi) >= 1.8 for package: 1:facter-1.7.2-1.el6.x86_64
--> Processing Dependency: pciutils for package: 1:facter-1.7.2-1.el6.x86_64
---> Package hiera.noarch 0:1.2.1-1.el6 will be installed
--> Processing Dependency: rubygem-json for package: hiera-1.2.1-1.el6.noarch
---> Package libselinux-ruby.x86_64 0:2.0.94-5.3.el6_4.1 will be installed
---> Package ruby.x86_64 0:1.8.7.352-12.el6_4 will be installed
---> Package ruby-augeas.x86_64 0:0.4.1-1.el6 will be installed
--> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas-0.4.1-1.el6.x86_64
---> Package ruby-rgen.noarch 0:0.6.5-1.el6 will be installed
---> Package ruby-shadow.x86_64 0:1.4.1-13.el6 will be installed
--> Running transaction check
---> Package augeas-libs.x86_64 0:0.9.0-4.el6 will be installed
---> Package pciutils.x86_64 0:3.1.10-2.el6 will be installed
---> Package ruby-libs.x86_64 0:1.8.7.352-12.el6_4 will be installed
--> Processing Dependency: libreadline.so.5()(64bit) for package: ruby-libs-1.8.7.352-12.el6_4.x86_64
---> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-json-1.5.5-1.el6.x86_64
--> Running transaction check
---> Package compat-readline5.x86_64 0:5.2-17.1.el6 will be installed
---> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-json-1.5.5-1.el6.x86_64
--> Finished Dependency Resolution
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 2 Perry Myers 2013-09-02 09:11:03 EDT
This issue is for RDO not RHOS, so moving the Product in bugzilla to RDO.

@yrabl: Ruby 1.8.7 is available in RHEL 6.4.  It looks like perhaps you don't have access to install from core RHEL repositories?

RDO requires access to both the RHEL Server repos (6.4 base and 6.4.z updates) as well as EPEL.

Can you please run:

sudo yum repolist

and then also run:

sudo yum list ruby

Thanks!
Comment 3 Yogev Rabl 2013-09-03 02:50:00 EDT
@pmyers: the result is 
ruby.x86_64             1.8.7.352-12.el6_4              @pulp-rhel-6-server-rpms
Comment 4 Martina Kollarova 2013-09-11 13:02:12 EDT
I have the exact same problem - packstack wants to install rubygem-json, which requires rubygem that isn't in the repo. My version of ruby is 1.8.7.352-12.el6_4 too.

repolist:

epel                                                             epel                                                                                                   9,517+54
foreman                                                          Foreman stable                                                                                            189+3
foreman-plugins                                                  Foreman stable - plugins                                                                                     20
openstack-havana                                                 OpenStack Havana Repository                                                                              287+80
puddle                                                           Condensed cloud puddle                                                                                   357+88
puppetlabs-deps                                                  Puppet Labs Dependencies El 6 - x86_64                                                                       49
puppetlabs-products                                              Puppet Labs Products El 6 - x86_64                                                                          294
rdo-havana                                                       rdo-havana                                                                                               287+80
rhel-x86_64-server-6                                             Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64)                                             10,654+248
rhel-x86_64-server-6-beta                                        Red Hat Enterprise Linux Server Beta (v. 6 for 64-bit x86_64)                                                 0
rhel-x86_64-server-ha-6                                          RHEL Server High Availability (v. 6 for 64-bit x86_64)                                                      269
rhel-x86_64-server-lb-6                                          RHEL Server Load Balancer (v. 6 for 64-bit x86_64)                                                           11
rhel-x86_64-server-sfs-6                                         RHEL Server Scalable File System (v. 6 for x86_64)                                                           32
Comment 5 Pádraig Brady 2013-09-11 14:36:46 EDT
rubygems is in the 'optional' repo

Bug #974971 is related (packstack should auto enable 'optional')

Note You need to log in before you can comment on or make changes to this bug.