Bug 1003512 - Schema validatation doesn't work in mtom enabled provider service
Schema validatation doesn't work in mtom enabled provider service
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
TBD EAP 6
Unspecified Unspecified
unspecified Severity unspecified
: ER7
: EAP 6.2.0
Assigned To: Alessio Soldano
Rostislav Svoboda
Russell Dickenson
:
Depends On: 1021549
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 04:51 EDT by Jim Ma
Modified: 2013-12-15 11:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA CXF-5237 None None None Never

  None (edit)
Description Jim Ma 2013-09-02 04:51:32 EDT
19:02:50,096 WARNING [org.apache.cxf.phase.PhaseInterceptorChain] (http-/127.0.0.1:8080-1) Interceptor for
{http://provider.gss.redhat.com/}

HelloWS#
{http://provider.gss.redhat.com/}

hello has thrown exception, unwinding now: org.apache.cxf.interceptor.Fault: Could not parse the XML stream caused by: org.xml.sax.SAXParseException: cvc-type.3.1.2: Element 'file' is a simple type, so it must have no element information item [children]..
at org.apache.cxf.databinding.source.XMLStreamDataReader.read(XMLStreamDataReader.java:160)
at org.apache.cxf.databinding.source.XMLStreamDataReader.read(XMLStreamDataReader.java:75)
at org.apache.cxf.databinding.source.XMLStreamDataReader.read(XMLStreamDataReader.java:60)
at org.apache.cxf.interceptor.DocLiteralInInterceptor.handleMessage(DocLiteralInInterceptor.java:203)
at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:262)
at org.apache.cxf.transport.ChainInitiationObserver.onMessage(ChainInitiationObserver.java:121)
at org.apache.cxf.transport.http.AbstractHTTPDestination.invoke(AbstractHTTPDestination.java:237)
Comment 1 Kyle Lape 2013-09-05 17:37:36 EDT
Proposing for 6.2 since this fix should be in CXF 2.7.7, but I'm not sure if the fact that the proper fix requires msv-core.jar affects whether this will make it into EAP 6.2 or not.
Comment 5 Rostislav Svoboda 2013-11-08 05:22:09 EST
Verified on EAP 6.2.0 ER7 using org.apache.cxf.systest.mtom_schema_validation.MTOMProviderSchemaValidationTest from cxf-2.7.7 tag.

pom.xml from cxf-2.7.7/systests/uncategorized modified to use cxf 2.7.6.redhat-2 and 2.7.7.redhat-1.

with 2.7.6.redhat-2 test fails 
javax.xml.ws.soap.SOAPFaultException: Could not parse the XML stream caused by: org.xml.sax.SAXParseException: cvc-type.3.1.2: Element 'file' is a simple type, so it must have no element information item [children]..

with 2.7.7.redhat-1 test passes

Note You need to log in before you can comment on or make changes to this bug.