Bug 1003521 - missing status as string in volume status and rebalance/remove-brick status commands
missing status as string in volume status and rebalance/remove-brick status c...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: cli (Show other bugs)
3.4.0
Unspecified Unspecified
medium Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On: 955611
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 05:05 EDT by Aravinda VK
Modified: 2014-04-17 07:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 955611
Environment:
Last Closed: 2014-04-17 07:46:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Aravinda VK 2013-09-02 05:08:22 EDT
Patch sent for review
http://review.gluster.org/#/c/5739/
Comment 2 Anand Avati 2013-09-02 05:10:46 EDT
REVIEW: http://review.gluster.org/5739 (cli: Add statusStr xml tag to task list and rebalance/remove brick status) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Anand Avati 2013-09-03 07:32:36 EDT
REVIEW: http://review.gluster.org/5739 (cli: Add statusStr xml tag to task list and rebalance/remove brick status) posted (#3) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 4 Anand Avati 2013-09-03 09:28:55 EDT
REVIEW: http://review.gluster.org/5739 (cli: Add statusStr xml tag to task list and rebalance/remove brick status) posted (#4) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 5 Anand Avati 2013-09-12 13:58:19 EDT
COMMIT: http://review.gluster.org/5739 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit cd7951aa31ae4bbdf35fc6d1f2466636844b889d
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Aug 30 14:37:03 2013 +0530

    cli: Add statusStr xml tag to task list and rebalance/remove brick status
    
    New xml tag statusStr added to following gluster cli commands
    gluster volume status all --xml (For Task status)
    gluster volume rebalance <VOLNAME> status --xml
    gluster volume remove-brick <VOLNAME> <BRICK1..> status --xml
    
    Example(volume status all):
    <task>
        <type>Rebalance</type>
        <id>82d8d122-8738-4144-8507-d93fc98b61df</id>
        <status>3</status>
        <statusStr>completed</statusStr>
    </task>
    
    Example(volume rebalance <VOL> status)
    <node>
        <nodeName>localhost</nodeName>
        <files>0</files>
        <size>0</size>
        <lookups>0</lookups>
        <failures>0</failures>
        <status>3</status>
        <statusStr>completed</statusStr>
    </node>
    
    Also modified task status as string instead of showing number
    in gluster volume status all
    
    Example:
    Status of volume: gv1
    Gluster process                                         Port    Online  Pid
    ------------------------------------------------------------------------------
    Brick sumne.sumne:/gfs/b1                               49154   Y       15489
    Brick sumne.sumne:/gfs/b2                               49155   Y       15493
    NFS Server on localhost                                 N/A     N       15913
    
               Task                                      ID         Status
               ----                                      --         ------
          Rebalance    82d8d122-8738-4144-8507-d93fc98b61df      completed
    
    BUG: 1003521
    Change-Id: Ib283016af4c18132fb13fb33d44075782d77823c
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    Reviewed-on: http://review.gluster.org/5739
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 6 Anand Avati 2013-09-19 06:43:07 EDT
REVIEW: http://review.gluster.org/5969 (cli: Add statusStr xml tag to task list and rebalance/remove brick status) posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 7 Anand Avati 2013-09-19 13:29:14 EDT
COMMIT: http://review.gluster.org/5969 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit c8e970495d24af1303b4dda8da9ac7bd6c8849fe
Author: Kaushal M <kaushal@redhat.com>
Date:   Fri Aug 30 14:37:03 2013 +0530

    cli: Add statusStr xml tag to task list and rebalance/remove brick status
    
     Backport of cd7951aa31ae4bbdf35fc6d1f2466636844b889d from master
    
    New xml tag statusStr added to following gluster cli commands
    gluster volume status all --xml (For Task status)
    gluster volume rebalance <VOLNAME> status --xml
    gluster volume remove-brick <VOLNAME> <BRICK1..> status --xml
    
    Example(volume status all):
    <task>
        <type>Rebalance</type>
        <id>82d8d122-8738-4144-8507-d93fc98b61df</id>
        <status>3</status>
        <statusStr>completed</statusStr>
    </task>
    
    Example(volume rebalance <VOL> status)
    <node>
        <nodeName>localhost</nodeName>
        <files>0</files>
        <size>0</size>
        <lookups>0</lookups>
        <failures>0</failures>
        <status>3</status>
        <statusStr>completed</statusStr>
    </node>
    
    Also modified task status as string instead of showing number
    in gluster volume status all
    
    Example:
    Status of volume: gv1
    Gluster process                                         Port    Online  Pid
    ------------------------------------------------------------------------------
    Brick sumne.sumne:/gfs/b1                               49154   Y       15489
    Brick sumne.sumne:/gfs/b2                               49155   Y       15493
    NFS Server on localhost                                 N/A     N       15913
    
               Task                                      ID         Status
               ----                                      --         ------
          Rebalance    82d8d122-8738-4144-8507-d93fc98b61df      completed
    
    BUG: 1003521
    Change-Id: I2f6845b621cbd5a74aeb3a3195f944536745e0ec
    Original-author: Aravinda VK <avishwan@redhat.com>
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5969
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 07:46:59 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.