Bug 1003632 - Failed Power On VM (VirtIO disk type) with Windows OS after live resize disk action.
Failed Power On VM (VirtIO disk type) with Windows OS after live resize disk ...
Status: CLOSED DUPLICATE of bug 1003629
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Sergey Gotliv
vvyazmin@redhat.com
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 10:21 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 12:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-15 10:27:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (4.46 MB, application/x-gzip)
2013-09-02 10:21 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-09-02 10:21:41 EDT
Created attachment 792858 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
Failed Power On VM (VirtIO disk type) with Windows OS after live resize disk action.

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS12 environment:

RHEVM:  rhevm-3.3.0-0.18.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.12-1.el6ev.noarch
VDSM:  vdsm-4.12.0-92.gita04386d.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.7.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. On FCP Data Center create VM with VirtIO disk type and 20 GB disk size
2. Install Windows OS (Windows 7 or Windows 2008). Finish installation process.
3. During running VM resize VM’s disk size to 25GB
4. OS stuck
5. Power Off VM
6. Try Power On VM

Actual results:
Failed Power ON VM

Expected results:
Successfully Power ON VM

Impact on user:
Failed Power On VM

Workaround:
none

Additional info:
* No problem found with Linux OS
* Failed Power ON VM with Windows OS on RAW and QCOW2 disks

/var/log/ovirt-engine/engine.log


2013-09-02 14:37:14,052 ERROR [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-93) Rerun vm e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9. Called fro
m vds tigris01.scl.lab.tlv.redhat.com
2013-09-02 14:37:14,108 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-45) Correlation ID: 531a9942, Job ID: d349ae0a-4d28-4ed3-93f0
-24f139b6f9b8, Call Stack: null, Custom Event ID: -1, Message: Failed to run VM vm_0003_B on Host tigris01.scl.lab.tlv.redhat.com.
2013-09-02 14:37:14,117 INFO  [org.ovirt.engine.core.bll.RunVmCommand] (pool-5-thread-45) Lock Acquired to object EngineLock [exclusiveLocks= key: e75eb88a-7f04-44ed-bb3e-ef57f8
2cb9c9 value: VM
, sharedLocks= ]
2013-09-02 14:37:14,188 INFO  [org.ovirt.engine.core.vdsbroker.IsVmDuringInitiatingVDSCommand] (pool-5-thread-45) START, IsVmDuringInitiatingVDSCommand( vmId = e75eb88a-7f04-44e
d-bb3e-ef57f82cb9c9), log id: 2f3fb9fd
2013-09-02 14:37:14,189 INFO  [org.ovirt.engine.core.vdsbroker.IsVmDuringInitiatingVDSCommand] (pool-5-thread-45) FINISH, IsVmDuringInitiatingVDSCommand, return: false, log id: 
2f3fb9fd
2013-09-02 14:37:14,286 INFO  [org.ovirt.engine.core.bll.RunVmCommand] (pool-5-thread-45) Running command: RunVmCommand internal: false. Entities affected :  ID: e75eb88a-7f04-4
4ed-bb3e-ef57f82cb9c9 Type: VM
2013-09-02 14:37:14,499 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.IsoPrefixVDSCommand] (pool-5-thread-45) START, IsoPrefixVDSCommand(HostName = tigris02.scl.lab.tlv.redha
t.com, HostId = b158905b-54f4-4069-ac7c-0ac8791edd98, storagePoolId=1e157529-0537-4696-8a6d-9b4be4680e44), log id: 420e6c31
2013-09-02 14:37:14,499 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.IsoPrefixVDSCommand] (pool-5-thread-45) FINISH, IsoPrefixVDSCommand, return: /rhev/data-center/mnt/wolf.
qa.lab.tlv.redhat.com:_volumes_wolf_kipi-iso/36f3a8b1-bf9e-4daf-a156-0df2a4785fa4/images/11111111-1111-1111-1111-111111111111, log id: 420e6c31
2013-09-02 14:37:14,506 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (pool-5-thread-45) START, CreateVmVDSCommand(HostName = tigris02.scl.lab.tlv.redhat.com, HostI
d = b158905b-54f4-4069-ac7c-0ac8791edd98, vmId=e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9, vm=VM [vm_0003_B]), log id: 722f9671
2013-09-02 14:37:14,539 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand] (pool-5-thread-45) START, CreateVDSCommand(HostName = tigris02.scl.lab.tlv.redhat.com,
 HostId = b158905b-54f4-4069-ac7c-0ac8791edd98, vmId=e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9, vm=VM [vm_0003_B]), log id: 2c7dfa9d
2013-09-02 14:37:14,646 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand] (pool-5-thread-45) org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand spiceSsl
CipherSuite=DEFAULT,memSize=1024,kvmEnable=true,smp=1,vmType=kvm,emulatedMachine=rhel6.4.0,keyboardLayout=en-us,memGuaranteedSize=1024,nice=0,display=qxl,smartcardEnable=false,s
mpCoresPerSocket=1,spiceSecureChannels=smain,sinputs,scursor,splayback,srecord,sdisplay,susbredir,ssmartcard,timeOffset=0,transparentHugePages=true,vmId=e75eb88a-7f04-44ed-bb3e-
ef57f82cb9c9,devices=[Ljava.util.HashMap;@1c5ab3c3,acpiEnable=true,vmName=vm_0003_B,cpuType=Opteron_G3,custom={}
2013-09-02 14:37:14,646 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.CreateVDSCommand] (pool-5-thread-45) FINISH, CreateVDSCommand, log id: 2c7dfa9d
2013-09-02 14:37:14,673 INFO  [org.ovirt.engine.core.vdsbroker.CreateVmVDSCommand] (pool-5-thread-45) FINISH, CreateVmVDSCommand, return: WaitForLaunch, log id: 722f9671
2013-09-02 14:37:14,673 INFO  [org.ovirt.engine.core.bll.RunVmCommand] (pool-5-thread-45) Lock freed to object EngineLock [exclusiveLocks= key: e75eb88a-7f04-44ed-bb3e-ef57f82cb
9c9 value: VM
, sharedLocks= ]
2013-09-02 14:37:14,676 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-45) Correlation ID: 531a9942, Job ID: d349ae0a-4d28-4ed3-93f0-24f139b6f9b8, Call Stack: null, Custom Event ID: -1, Message: VM vm_0003_B was started by admin@internal (Host: tigris02.scl.lab.tlv.redhat.com).
2013-09-02 14:37:16,835 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (DefaultQuartzScheduler_Worker-37) START, DestroyVDSCommand(HostName = tigris02.scl.lab.tlv.redhat.com, HostId = b158905b-54f4-4069-ac7c-0ac8791edd98, vmId=e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9, force=false, secondsToWait=0, gracefully=false), log id: 673f7d7a
2013-09-02 14:37:17,902 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DestroyVDSCommand] (DefaultQuartzScheduler_Worker-37) FINISH, DestroyVDSCommand, log id: 673f7d7a
2013-09-02 14:37:18,066 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-37) Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: VM vm_0003_B is down. Exit message: internal error boot orders have to be contiguous and starting from 1.
2013-09-02 14:37:18,067 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-37) Running on vds during rerun failed vm: null
2013-09-02 14:37:18,068 INFO  [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-37) vm vm_0003_B running in db and not running in vds - add to rerun treatment. vds tigris02.scl.lab.tlv.redhat.com
2013-09-02 14:37:18,108 ERROR [org.ovirt.engine.core.vdsbroker.VdsUpdateRunTimeInfo] (DefaultQuartzScheduler_Worker-37) Rerun vm e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9. Called from vds tigris02.scl.lab.tlv.redhat.com


/var/log/vdsm/vdsm.log

Thread-212715::DEBUG::2013-09-02 12:37:18,319::libvirtconnection::101::libvirtconnection::(wrapper) Unknown libvirterror: ecode: 1 edom: 20 level: 2 message: internal error boot
 orders have to be contiguous and starting from 1
Thread-212715::DEBUG::2013-09-02 12:37:18,319::vm::2038::vm.Vm::(_startUnderlyingVm) vmId=`e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9`::_ongoingCreations released
Thread-212715::ERROR::2013-09-02 12:37:18,319::vm::2064::vm.Vm::(_startUnderlyingVm) vmId=`e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9`::The vm start process failed
Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 2024, in _startUnderlyingVm
    self._run()
  File "/usr/share/vdsm/vm.py", line 2919, in _run
    self._connection.createXML(domxml, flags),
  File "/usr/lib64/python2.6/site-packages/vdsm/libvirtconnection.py", line 76, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2645, in createXML
    if ret is None:raise libvirtError('virDomainCreateXML() failed', conn=self)
libvirtError: internal error boot orders have to be contiguous and starting from 1
Dummy-2698::DEBUG::2013-09-02 12:37:18,325::storage_mailbox::727::Storage.Misc.excCmd::(_checkForMail) 'dd if=/rhev/data-center/1e157529-0537-4696-8a6d-9b4be4680e44/mastersd/dom
_md/inbox iflag=direct,fullblock count=1 bs=1024000' (cwd None)
Thread-212715::DEBUG::2013-09-02 12:37:18,394::vm::2454::vm.Vm::(setDownStatus) vmId=`e75eb88a-7f04-44ed-bb3e-ef57f82cb9c9`::Changed state to Down: internal error boot orders ha
ve to be contiguous and starting from 1
Comment 1 Ayal Baron 2013-09-15 10:27:37 EDT

*** This bug has been marked as a duplicate of bug 1003629 ***

Note You need to log in before you can comment on or make changes to this bug.