This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1003671 - Pager buttons - cannot read description
Pager buttons - cannot read description
Status: CLOSED WONTFIX
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Mauricio Salatino
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 12:12 EDT by Zuzana Krejčová
Modified: 2014-11-27 20:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-27 20:00:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
button description covered (2.93 KB, image/png)
2013-09-02 12:12 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-09-02 12:12:45 EDT
Created attachment 792923 [details]
button description covered

Description of problem:
The buttons for browsing through pages have a description / title. Thanks to these buttons location (at the very bottom) and the fact, that the description pups up below them, the description cannot be read. See screenshot.

What happens is this:
You move your cursor over the button and leave it there for a bit. The description appears. This makes the page bigger, which means that scrollbars appear as well. These scrollbars are over the description, almost completely covering it.
Scrolling down to see more of the page means that your cursor leaves the button. The description disappears. This makes the page smaller again, there's no need for scrollbars and you go full circle - back to the button and description popping up, being covered...


Version-Release number of selected component (if applicable):
BPMS 6.0 ER2
Comment 1 Zuzana Krejčová 2013-09-02 12:15:07 EDT
Forgot to add:
This happens for pager buttons in Process Instances perspective and Tasks perspective.
If it weren't for bug 1003667, I'm quite sure we could see the same for Process Definitions perspective.
Comment 2 Mauricio Salatino 2013-09-03 04:45:44 EDT
This problem is related with how the gwt pagers are. It's not in the BPMS side at all. We need more advanced pagers and grids provided by the Uberfire or Kie-Commons team. Until we don't have that there it not much that we can do
Comment 3 Zuzana Krejčová 2013-09-03 04:57:13 EDT
(In reply to Mauricio Salatino from comment #2)
> This problem is related with how the gwt pagers are. It's not in the BPMS
> side at all. We need more advanced pagers and grids provided by the Uberfire
> or Kie-Commons team. Until we don't have that there it not much that we can
> do

Well, BPMS side could also use the same pagers that BRMS side uses (bug 996869), although those don't have any description at all. In this case, it is probably better, since having a description you cannot read can be quite infuriating.
Comment 4 Kris Verlaenen 2014-11-27 20:00:52 EST
With the new tables this is no longer relevant I believe.

Note You need to log in before you can comment on or make changes to this bug.