Bug 1003672 - add rescue boot option to liveCD
add rescue boot option to liveCD
Status: CLOSED DUPLICATE of bug 1176580
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-02 12:13 EDT by Jann
Modified: 2015-08-27 13:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 13:43:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jann 2013-09-02 12:13:24 EDT
There are quite a few new users on the ask.fedoraproject.org website which get confused when the try to fix their grub2. New users often want to dual-boot with windows (understandably) but the windows installer is not so nice, and it removes grub from the mbr/gpt. Therefore, these users often find them selves in the situation that they need to reinstall grub, and reconfigure grub such that it now recognizes the newly installed OS.

The install-media have a nice rescue mode, which is nicely documented in the manual (see, http://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/ch-Boot-x86.html#sn-boot-menu-x86). And after booting in rescue mode a user can perform:

chroot /mnt/sysimage 
grub2-install /dev/sda 
grub2-mkconfig -o /boot/grub2/grub.cfg

However, many users install fedora with the liveCD, which does not have this rescue boot feature. And i'm puzzled to why?


Request: Add the rescue boot option to the liveCD's
Comment 2 Chris Lumens 2015-08-27 13:43:23 EDT

*** This bug has been marked as a duplicate of bug 1176580 ***

Note You need to log in before you can comment on or make changes to this bug.