This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1003842 - AFR: Mount crash lead to data corruption when a brick is down
AFR: Mount crash lead to data corruption when a brick is down
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On: 1003757
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 06:45 EDT by Pranith Kumar K
Modified: 2014-04-17 07:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003757
Environment:
Last Closed: 2014-04-17 07:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-03 06:54:03 EDT
REVIEW: http://review.gluster.org/5763 (cluster/afr: Set size based source only when sizes are unequal) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-09-04 00:38:25 EDT
COMMIT: http://review.gluster.org/5763 committed in master by Anand Avati (avati@redhat.com) 
------
commit 2c15621d26fda5ba21e375d803baa5d8e09e6260
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Tue Sep 3 13:30:13 2013 +0530

    cluster/afr: Set size based source only when sizes are unequal
    
    Change-Id: I18583f14edf1011401be15744371e2a6b79d75cc
    BUG: 1003842
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5763
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Niels de Vos 2014-04-17 07:47:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.