Bug 1003845 - Samba packages other than samba_glusterfs should not be dependent on glusterfs packages
Samba packages other than samba_glusterfs should not be dependent on glusterf...
Status: CLOSED EOL
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jose A. Rivera
surabhi
package
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 07:02 EDT by surabhi
Modified: 2015-12-03 12:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-03 12:22:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surabhi 2013-09-03 07:02:20 EDT
Description of problem:
While doing a yum update it shows the samba packages dependency on glusterfs packages and does not install the samba.

[root@RHSVM1 yum.repos.d]# yum update -y
Loaded plugins: aliases, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, product-id, protectbase, rhnplugin, security, subscription-manager,
              : tmprepo, tsflags, upgrade-helper, verify, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Loading mirror speeds from cached hostfile
Skipping filters plugin, no data
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
Skipping filters plugin, no data
--> Running transaction check
---> Package libsmbclient.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package libsmbclient.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package libsmbclient-devel.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package libsmbclient-devel.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-client.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-client.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-common.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-common.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-debuginfo.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-debuginfo.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-doc.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-doc.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-domainjoin-gui.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-domainjoin-gui.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-swat.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-swat.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-winbind.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-winbind.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-winbind-clients.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-winbind-clients.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-winbind-devel.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-winbind-devel.x86_64 0:3.6.9-160.3.el6rhs will be an update
---> Package samba-winbind-krb5-locator.x86_64 0:3.6.9-160.1.el6rhs will be updated
---> Package samba-winbind-krb5-locator.x86_64 0:3.6.9-160.3.el6rhs will be an update
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================================================================================
 Package                                               Arch                              Version                                         Repository                                      Size
==============================================================================================================================================================================================
Updating:
 libsmbclient                                          x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                            1.6 M
 libsmbclient-devel                                    x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             82 k
 samba                                                 x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                            5.0 M
 samba-client                                          x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             11 M
 samba-common                                          x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             10 M
 samba-debuginfo                                       x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             57 M
 samba-doc                                             x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             12 M
 samba-domainjoin-gui                                  x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             88 k
 samba-swat                                            x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                            7.3 M
 samba-winbind                                         x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                            2.1 M
 samba-winbind-clients                                 x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                            2.0 M
 samba-winbind-devel                                   x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             68 k
 samba-winbind-krb5-locator                            x86_64                            3.6.9-160.3.el6rhs                              rhs2.1-samba-server                             66 k

Transaction Summary
==============================================================================================================================================================================================
Upgrade      13 Package(s)

Total size: 109 M
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libgfapi.so.0()(64bit) is needed by samba-winbind-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-winbind-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-winbind-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-winbind-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by samba-common-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-common-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-common-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-common-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by samba-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by samba-client-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-client-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-client-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-client-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by samba-domainjoin-gui-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-domainjoin-gui-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-domainjoin-gui-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-domainjoin-gui-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by samba-swat-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-swat-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-swat-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-swat-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by samba-winbind-clients-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by samba-winbind-clients-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by samba-winbind-clients-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by samba-winbind-clients-0:3.6.9-160.3.el6rhs.x86_64
libgfapi.so.0()(64bit) is needed by libsmbclient-0:3.6.9-160.3.el6rhs.x86_64
libgfrpc.so.0()(64bit) is needed by libsmbclient-0:3.6.9-160.3.el6rhs.x86_64
libgfxdr.so.0()(64bit) is needed by libsmbclient-0:3.6.9-160.3.el6rhs.x86_64
libglusterfs.so.0()(64bit) is needed by libsmbclient-0:3.6.9-160.3.el6rhs.x86_64
** Found 40 pre-existing rpmdb problem(s), 'yum check' output follows:
libsmbclient-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
libsmbclient-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
libsmbclient-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
libsmbclient-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of gluster-swift
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of gluster-swift-plugin
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of glusterfs >= ('0', '3.4.0', None)
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of glusterfs-fuse
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of glusterfs-geo-replication
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of glusterfs-server
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of samba-glusterfs
redhat-storage-server-2.1.0-3.el6rhs.noarch has missing requires of vdsm-gluster
samba-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
samba-client-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-client-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-client-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-client-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
samba-common-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-common-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-common-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-common-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
samba-domainjoin-gui-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-domainjoin-gui-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-domainjoin-gui-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-domainjoin-gui-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
samba-swat-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-swat-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-swat-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-swat-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
samba-winbind-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-winbind-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-winbind-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-winbind-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
samba-winbind-clients-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfapi.so.0()(64bit)
samba-winbind-clients-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfrpc.so.0()(64bit)
samba-winbind-clients-3.6.9-160.1.el6rhs.x86_64 has missing requires of libgfxdr.so.0()(64bit)
samba-winbind-clients-3.6.9-160.1.el6rhs.x86_64 has missing requires of libglusterfs.so.0()(64bit)
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2013-09-02-02-11nsqHMb.yumtx

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Do yum update
2.
3.

Actual results:
Samba packages does not get updated and shows dependency errors.

Expected results:
Out of 14 samba packages only one is dependent on glusterfs so even if glusterfs is not installed the 13 samba packages should get installed and should not show dependency errors.

Additional info:
Comment 2 Raghavendra Talur 2013-09-03 13:40:33 EDT
As Expected results states:
Out of 14 samba packages only one is dependent on glusterfs so even if glusterfs is not installed the 13 samba packages should get installed and should not show dependency errors.




Problem only occurs when samba update is tried with gluster not being installed.
Changing the summary to reflect this point.
Comment 7 surabhi 2013-09-04 04:47:10 EDT
As per discussion it is clarified that this issue might not come for RHEL/upstream.But for RHS the samba packages other than glusterfs_samba should not be dependent upon glusterfs packages.
Comment 8 Vivek Agarwal 2015-12-03 12:22:01 EST
Thank you for submitting this issue for consideration in Red Hat Gluster Storage. The release for which you requested us to review, is now End of Life. Please See https://access.redhat.com/support/policy/updates/rhs/

If you can reproduce this bug against a currently maintained version of Red Hat Gluster Storage, please feel free to file a new report against the current release.

Note You need to log in before you can comment on or make changes to this bug.