Bug 1003855 - upgrade: NFS client returns "Invalid argument" while creating directories/file after upgrade
upgrade: NFS client returns "Invalid argument" while creating directories/fil...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 1003582
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 07:32 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1003582
Environment:
Last Closed: 2014-04-17 07:47:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-03 07:37:25 EDT
REVIEW: http://review.gluster.org/5764 (mgmt/glusterd: Regenerate client volfiles during upgrade) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-09-04 00:40:23 EDT
COMMIT: http://review.gluster.org/5764 committed in master by Anand Avati (avati@redhat.com) 
------
commit 98df12f040d95d6a26047f03988b120984f7439e
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue Sep 3 16:30:33 2013 +0530

    mgmt/glusterd: Regenerate client volfiles during upgrade
    
    Change-Id: I1442bc1d115a9c6ecf139a0ca9da74d07e0fe928
    BUG: 1003855
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5764
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 5 Niels de Vos 2014-04-17 07:47:09 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.