Bug 1003884 - systemd is not able create predictable MAC-based ethX network interface names
systemd is not able create predictable MAC-based ethX network interface names
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 08:26 EDT by Frantisek Hanzlik
Modified: 2013-09-10 10:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 10:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frantisek Hanzlik 2013-09-03 08:26:32 EDT
Description of problem:
It seems as F19 induced restriction in creating MAC (HW ether addr) based netvork interfaces for kernel native names ethN - it is relatively simple to create predictable MAC-based netvork interface with some other names (e.g. netX),
but creating predictable MAC-based ethX netvork interface names isn't possible - at least with new systemd/udev interface.
'net.ifnames=0'/'NULL /etc/udev/rules.d/80-net-name-slot.rules' is solution for machine with only one interface, thus unacceptable.

This should be _bug_, as these names are here ~20 years (whole time the Linux is here), and there are lot of scripts and utilities which expect this naming.

Version-Release number of selected component (if applicable):
systemd-204-8.fc19.i686.rpm
systemd-204-9.fc19.i686.rpm

Additional info:
Although is possible solve this problem beside of systemd/udev system initialization phase with some user scripting, this should be systemd task.
Comment 1 Zbigniew Jędrzejewski-Szmek 2013-09-10 10:58:44 EDT
Are you saying that it's not possible to rename interfaces *into* the ethX namespace? (E.g. have eth0 renamed to eth1, and eth1 to eth...). That's not supported inded, because it was racy. Even if it worked for a long time, computers are faster now, and the bootup sequence less predictable, and this just isn't supported anymore. For a longer explanation see "Why?" section in
http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/ or https://bugs.freedesktop.org/show_bug.cgi?id=56929#c3.

Note You need to log in before you can comment on or make changes to this bug.