Bug 1003915 - PartitionException: Can't have overlapping partitions.
PartitionException: Can't have overlapping partitions.
Status: CLOSED DUPLICATE of bug 989766
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:26dab3705dc09a1266c7948561c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 10:01 EDT by Martin Bříza
Modified: 2013-09-04 14:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 14:07:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (791.81 KB, text/plain)
2013-09-03 10:01 EDT, Martin Bříza
no flags Details
File: anaconda.log (16.77 KB, text/plain)
2013-09-03 10:01 EDT, Martin Bříza
no flags Details
File: environ (673 bytes, text/plain)
2013-09-03 10:01 EDT, Martin Bříza
no flags Details
File: lsblk_output (1.78 KB, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: nmcli_dev_list (14.21 KB, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: os_info (179 bytes, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: program.log (66.82 KB, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: storage.log (120.82 KB, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: syslog (117.96 KB, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: ifcfg.log (394 bytes, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details
File: packaging.log (334.04 KB, text/plain)
2013-09-03 10:02 EDT, Martin Bříza
no flags Details

  None (edit)
Description Martin Bříza 2013-09-03 10:01:38 EDT
Description of problem:
Installing Fedora 19 from local PXE.
When in the disk formatting tool, I selected my previous Fedora installation which was on a single "7.952 GB" partition which it was using for "/".
I set this particular partition (without deleting) to be used as "/" again, checked "Reformat" and changed its size to "15.952 GB". Then I clicked "Done" (or what is written on the button in the upper left corner, the whole UI is now stuck).
At this point, the "Report bug or Quit" dialog appeared.

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 309, in setPartitionGeometry
    start, end)
  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 41, in new
    ret = fn(*args, **kwds)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 1249, in _setTargetSize
    start=geometry.start, end=geometry.end)
  File "/usr/lib/python2.7/site-packages/blivet/devices.py", line 605, in <lambda>
    lambda s, v: s._setTargetSize(v),
  File "/usr/lib/python2.7/site-packages/blivet/deviceaction.py", line 400, in __init__
    self.device.targetSize = newsize
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1211, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1399, in _save_right_side
    self.__storage.resizeDevice(device, size)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1848, in on_back_clicked
    self._save_right_side(self._current_selector)
PartitionException: Can't have overlapping partitions.

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=/distrotrees/63224/initrd method=http://download-01.eng.brq.redhat.com/pub/fedora/linux/releases/19/Fedora/x86_64/os/ repo=http://download-01.eng.brq.redhat.com/pub/fedora/linux/releases/19/Fedora/x86_64/os/  BOOT_IMAGE=/distrotrees/63224/kernel 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Martin Bříza 2013-09-03 10:01:47 EDT
Created attachment 793199 [details]
File: anaconda-tb
Comment 2 Martin Bříza 2013-09-03 10:01:52 EDT
Created attachment 793200 [details]
File: anaconda.log
Comment 3 Martin Bříza 2013-09-03 10:01:56 EDT
Created attachment 793201 [details]
File: environ
Comment 4 Martin Bříza 2013-09-03 10:02:00 EDT
Created attachment 793202 [details]
File: lsblk_output
Comment 5 Martin Bříza 2013-09-03 10:02:06 EDT
Created attachment 793203 [details]
File: nmcli_dev_list
Comment 6 Martin Bříza 2013-09-03 10:02:10 EDT
Created attachment 793204 [details]
File: os_info
Comment 7 Martin Bříza 2013-09-03 10:02:14 EDT
Created attachment 793205 [details]
File: program.log
Comment 8 Martin Bříza 2013-09-03 10:02:19 EDT
Created attachment 793206 [details]
File: storage.log
Comment 9 Martin Bříza 2013-09-03 10:02:23 EDT
Created attachment 793207 [details]
File: syslog
Comment 10 Martin Bříza 2013-09-03 10:02:28 EDT
Created attachment 793208 [details]
File: ifcfg.log
Comment 11 Martin Bříza 2013-09-03 10:02:34 EDT
Created attachment 793209 [details]
File: packaging.log
Comment 12 Samantha N. Bueno 2013-09-04 14:07:22 EDT

*** This bug has been marked as a duplicate of bug 989766 ***

Note You need to log in before you can comment on or make changes to this bug.