This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1003957 - Make
Make
Status: CLOSED DUPLICATE of bug 1003959
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 10:53 EDT by Perry Myers
Modified: 2013-09-20 10:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 10:05:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Perry Myers 2013-09-03 10:53:29 EDT
From this discussion:
http://openstack.redhat.com/forum/discussion/519/puppet-fails-to-set-openvswitch-from-absent-to-present/p1

It's clear that the current error messages from yum when package installation fails are not really good enough.  Yum will just say "Nothing to do" which doesn't tell the user what really happened.

What we should do is have Packstack catch that sort of error from Yum/Puppet and let the user know that the issue is that the package in question was a dependency and it failed to install for some reason.
Comment 1 Martin Magr 2013-09-20 10:05:53 EDT

*** This bug has been marked as a duplicate of bug 1003959 ***

Note You need to log in before you can comment on or make changes to this bug.