Bug 100399 - installer for 8.0 fails immediately after starting X server
installer for 8.0 fails immediately after starting X server
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-21 20:30 EDT by alm
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-11 16:05:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description alm 2003-07-21 20:30:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

Description of problem:
As soon as all requested packages have been copied to the hard disk, the
installer starts the X server. The following output is printed to the console:

Waiting for X server to start... log located in /tmp/X.log
1...2...3...4...5...6.... X server started successfully

<the following is repeated seven times>
(anaconda:94) Gnome Canvas-CRITICAL**: file gnome-canvas-path-def.c line 1142
(gnome_canvas_path_def_any_closed): assertion 'path !=NULL' failed

install exited abnormally
sending termination signals ... done

...

You may safely reboot your system

<end of console output>



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot to first CD for Version 8.0
2.Follow instructions
3.
    

Actual Results:  The installation seemed to go normally until all requested
packages were copied to disk. The installation then failed with the message
indicated in the summary expansion

Expected Results:  A working version of Version 8.0

Additional info:

  I previously had version 7.3 installed on this hardware. Linux is on a scsi
disk and Windows 2000 is on an IDE disk with a dual boot using GRUB. GRUB no
longer works so I cannot boot to either Windows or Linux. The Linux disk was
reformatted (both automatic and manual) with error checking enabled on each
install attempt.
  I have switched CD drives and switched video cards without causing a change in
the result. I cannot get to the logs since a working operating system is not
left on the drive. I have tried to install custom and workstation versions with
and without requesting additional packages (even tried to install everything).
All attempts lead to the same results.
Comment 1 Jeremy Katz 2003-07-22 11:27:42 EDT
Have you verified your media following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html
Comment 2 alm 2003-07-22 20:56:07 EDT
The media were tested during several of the installation attempts. All the disks
passed. I had used these disks a few weeks ago to install 8.0 on my laptop.
I also used the 8.0-cdread.img patch on one of the attempts with no apparent
difference in the results.
Comment 3 Jeremy Katz 2003-07-24 18:36:41 EDT
Have you tried on this specific machine, though?  There are some errors in the
log that look a lot like problems actually reading off of the CD (and different
CD-ROM drives tend to have different tolerances for questionable CDs, especially
CD-Rs)
Comment 4 alm 2003-07-24 20:17:47 EDT
I have two machines on which I want to install 8.0. The first is a laptop. The
installation proceeded without a hitch. The second is a desktop. I have tried to
install six or eight times with variations in each try. Using two different CD
drives (on the desktop), I tested all the media and they passed. I used the
8.0-cdread.img patch with each drive for the installations. In all instances,
the result was the same - the log in my original message was reproduced.
Comment 5 Michael Fulbright 2003-07-31 15:25:40 EDT
How much RAM is in the desktop machine?
Comment 6 alm 2003-07-31 16:17:46 EDT
500MB, but I think that the problem has been identified. I had an old IDE disk
in the machine with a previous version of RedHat. Much of that installation had
been deleted since I was only using it to store data. I disconnected it from the
computer and tried to install RedHat 9.0. It worked like a charm. If the disk is
reattached, GRUB hangs up, so I am inclined to believe that the disk was the
problem. I have not tried 8.0, but my guess is that it would work in the same way. 

I believe there is an option with GRUB that is a kind of search option. If the
first disk in its list (probably the IDE disks first, then SCSI) doesn't work,
it will try the next. I haven't tried that yet, but it is next. I would like to
again use the disk for storage.

In any event, the computer now has a working version of RedHat. Thanks for the help.
Comment 7 Michael Fulbright 2003-08-11 16:05:59 EDT
Good to hear you found the problem.

Note You need to log in before you can comment on or make changes to this bug.