Bug 1004037 - RFE: Add qemu.conf option to set spice defaultMode="secure" if spice_tls=1
RFE: Add qemu.conf option to set spice defaultMode="secure" if spice_tls=1
Status: CLOSED WONTFIX
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-03 14:41 EDT by Anthony Messina
Modified: 2016-01-30 20:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-30 20:47:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 904295 None None None Never

  None (edit)
Description Anthony Messina 2013-09-03 14:41:40 EDT
Currently, a sysadmin can enable spice_tls, but this doesn't actually enforce the use of secured connections for spice channels.

Please add a new qemu.conf option 'spice_channel_default_mode' which maps to defaultMode if none is explicitly specified in the XML. So in addition to setting spice_tls=1, a syadmin could also set spice_channel_default_mode=secure to ensure that spice communication is handled securely.

Please see discussion in https://bugzilla.redhat.com/show_bug.cgi?id=904295
Comment 1 Anthony Messina 2016-01-30 20:47:11 EST
I don't use libvirt any longer.

Note You need to log in before you can comment on or make changes to this bug.