Bug 1004141 - Remove the downstream SQL script 03_03_0221_rhsc_downstream.sql which removes non Gluster roles
Remove the downstream SQL script 03_03_0221_rhsc_downstream.sql which removes...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity unspecified
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 00:21 EDT by Shubhendu Tripathi
Modified: 2015-05-13 12:27 EDT (History)
8 users (show)

See Also:
Fixed In Version: cb1
Doc Type: Bug Fix
Doc Text:
Previously, non-gluster roles were required to be removed explicitly from roles table for branding purpose. Now, with this update, the roles are listed based on the application mode and the roles does not get removed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:36:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18592 None None None Never

  None (edit)
Description Shubhendu Tripathi 2013-09-04 00:21:43 EDT
Description of problem:

There is a downstream only SQL script (03_03_0221_rhsc_downstream.sql) maintained which removes the non-gluster roles from roles table for branding purpose.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Shubhendu Tripathi 2013-09-05 02:54:47 EDT
Introduced a new field to roles table to represent the application mode.
This field identifies the application for which the role is meant for.

The set of roles would be listed based on the current application mode set for the installation.
Comment 3 Kanagaraj 2013-09-05 03:11:40 EDT
With this fix, rhsc should list the roles only which are relevant. Also the user should  be able to create a new role or modify an existing role.
Comment 4 Shruti Sampat 2013-10-04 07:21:17 EDT
Only roles which are relevant are being listed now. Creating, deleting and modifying existing roles works fine. Verified this in Red Hat Storage Console Version: 2.1.1-0.0.2.master.el6ev. Marking as VERIFIED.
Comment 5 Shalaka 2014-01-08 01:28:28 EST
Please review the edited DocText and signoff.
Comment 6 Shubhendu Tripathi 2014-01-08 03:32:23 EST
Doc text looks fine
Comment 8 errata-xmlrpc 2014-02-25 02:36:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.