Bug 1004145 - Failed to register ESX hypervisor to Stage Candlepin
Failed to register ESX hypervisor to Stage Candlepin
Status: CLOSED DUPLICATE of bug 1313053
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9.23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: candlepin-bugs
Katello QA List
:
Depends On: 1004905
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 01:05 EDT by gaoshang
Modified: 2016-09-30 10:42 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Multi-tenat support for virt-who Reason: Restricts guests on host to a single org. Result (if any); Will need to document the restriction of use in current release. Virt-who operation is inconsistent with ability of subscription services to support multi-tenant orgs.
Story Points: ---
Clone Of:
: 1004905 (view as bug list)
Environment:
Last Closed: 2016-09-30 10:42:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dlah: needinfo+


Attachments (Terms of Use)
virt-who log file (2.63 KB, text/plain)
2013-09-04 21:56 EDT, gaoshang
no flags Details

  None (edit)
Description gaoshang 2013-09-04 01:05:20 EDT
Description of problem:
When running virt-who in ESX mode, an ESX hypervisor host should be registered to Stage Candlepin, so we can register/subscribe ESX host via Stage web UI, thus bonus pool can be shown up in ESX guest, but this ESX host can't be created.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Configure virt-who in ESX mode, keep virt-who running
2. Register virt-who machine to Stage
3. Check systems in Stage web UI

Actual results:
ESX hypervisor host can not be registered to Stage.

Expected results:
Not only virt-who machine should be registered to Stage, but also an ESX hypervisor host should be registered.

Additional info:
Comment 2 Devan Goodwin 2013-09-04 10:28:48 EDT
Virt-who manpage says it should always log to /var/log/rhsm/rhsm.log, could we get a copy of this logfile attached to the bug please.
Comment 3 Michael Stead 2013-09-04 10:39:14 EDT
Are we able to get access to ESX that was used? i.e What are the details of virt-who's ESX configuration?
Comment 4 gaoshang 2013-09-04 21:56:34 EDT
Created attachment 793946 [details]
virt-who log file
Comment 6 Michael Stead 2013-09-05 08:14:53 EDT
Are there any errors that occur after the output of the host/guest mappings? The snippit in the attached log is rather short.
Comment 7 Michael Stead 2013-09-05 13:27:46 EDT
This appears to be an issue in candlepin when multiple systems are running virt-who against the same ESX server.

I believe there is an issue in candlepin's hypervisors API call. The host consumers do not show up b/c another system is running virt-who against the same ESX server and seems to have reported the host/guests first (with a different org). Therefore, the user used in the BZ wouldn't see the hypervisor consumers due to the org that they were initially created in.

Looking at the data in stage, the hypervisor typed consumers for the hosts reported by ESX server appear to have been created against another org.
Comment 8 Michael Stead 2013-09-10 13:17:20 EDT
This boils down to being a configuration issue. Multiple instances of virt-who are configured to report hosts/guests for the same hypervisor instance (vcenter).

We currently do not have multi-tenant support for virt-who instances reporting from the same ESX server. It is out of scope for the upcoming release to add this functionality, so an RFE will be created to address this issue.

Even providing better feedback to virt-who is very hard without being able to uniquely identify the hypervisor instance. Lets address this as part of the RFE.
Comment 9 Dan Lah 2013-10-04 18:01:56 EDT
The restriction of use in current release of Virt-who is inconsistent with ability of subscription services to support multi-tenant (SAM/SAT).

Note You need to log in before you can comment on or make changes to this bug.