Bug 1004173 - SRT does not display data for min and max metrics
SRT does not display data for min and max metrics
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: Gary Brown
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 02:58 EDT by Jiri Pechanec
Modified: 2015-08-02 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (42.44 KB, image/png)
2013-09-04 02:59 EDT, Jiri Pechanec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-268 Major Closed Service response time aggregation not performed correctly for min/max values 2014-07-02 05:19:28 EDT

  None (edit)
Description Jiri Pechanec 2013-09-04 02:58:14 EDT
See in attached screenshot - a service is called three times, there are different values for min, max and avg in active collection but the chart lines are same for all three metrics.
Comment 1 Jiri Pechanec 2013-09-04 02:59:07 EDT
Created attachment 793505 [details]
Screenshot

Notice the metrics in service overview and no difference in SRT gadget
Comment 2 Jiri Pechanec 2013-09-04 03:19:55 EDT
It seems that the issue is in active collection. If I execute the query manually then I get something like this
{
    "interface":"org.jboss.soa.qa.rtgsrt.SRTService",
    "timestamp":1378278790293,
    "min":1024,
    "max":1024,
    "serviceType":"{
    urn:switchyard-soa:rtgov_srt:0.1.0
}SRTTest/SRTService",
    "operation":"twoWay",
    "fault":null,
    "average":1024,
    "requestId":null,
    "responseId":null,
    "context":[],
    "properties":{
    
}
Comment 3 Jiri Pechanec 2013-09-04 04:37:01 EDT
AggregateServiceResponseTime.mvel uses only getAverage() calls never getMin() or getMax() - is it correct?
Comment 4 Gary Brown 2013-09-04 05:01:09 EDT
This is probably where the issue is - it averages based on the average value of each response time, setting the min/max values of those averages, rather doing an average calc for min, avg and max separately.
Comment 5 Gary Brown 2013-09-06 11:48:38 EDT
Have applied a change to the mvel script (https://github.com/Governance/rtgov/commit/9c547e723ff0608835c9992dcab3bf956f7d8a9e) - could you try this out, as not sure whether this is related to the issue you are seeing.

If not, then can you provide more information to help reproduce the problem scenario.
Comment 6 Jiri Pechanec 2013-09-09 09:53:57 EDT
It works as expected, good job
Comment 7 Jiri Pechanec 2013-09-24 06:20:06 EDT
Verified in ER3
Comment 11 JBoss JIRA Server 2014-07-02 05:19:28 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-268 to Closed

Note You need to log in before you can comment on or make changes to this bug.