Bug 1004219 - Upgrade: updating to Big Bend from U6 errors out with version mismatch
Upgrade: updating to Big Bend from U6 errors out with version mismatch
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Anthony Towns
Sachidananda Urs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 04:39 EDT by Sachidananda Urs
Modified: 2014-07-11 02:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2013-09-04 04:39:15 EDT
Description of problem:

[root@anshi-1 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.2 (Santiago)
[root@anshi-1 ~]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.2 (Santiago)
Kernel \r on an \m

[root@anshi-1 ~]# gluster --version
glusterfs 3.3.0.14rhs built on Aug 29 2013 09:33:47
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@anshi-1 ~]# 

[root@anshi-1 ~]# rhn-channel -l
rhel-x86_64-server-6-rhs-2.1
rhel-x86_64-server-6.4.z
rhel-x86_64-server-sfs-6.4.z
[root@anshi-1 ~]# 

After subscribing to 2.1 channels from U6 and do a yum update I see:

---> Package augeas-libs.i686 0:0.9.0-1.el6 will be installed
--> Processing Dependency: libselinux.so.1 for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.8) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2.3) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.2) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.1) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: augeas-libs-0.9.0-1.el6.i686
--> Processing Dependency: libc.so.6 for package: augeas-libs-0.9.0-1.el6.i686
---> Package augeas-libs.x86_64 0:0.9.0-1.el6 will be updated
---> Package device-mapper-persistent-data.x86_64 0:0.1.4-1.el6 will be installed
---> Package glusterfs-api.x86_64 0:3.4.0.30rhs-2.el6rhs will be installed
---> Package glusterfs-libs.x86_64 0:3.4.0.30rhs-2.el6rhs will be installed
---> Package libproxy.x86_64 0:0.3.0-4.el6_3 will be installed
--> Processing Dependency: libproxy-python = 0.3.0-4.el6_3 for package: libproxy-0.3.0-4.el6_3.x86_64
--> Processing Dependency: libproxy-bin = 0.3.0-4.el6_3 for package: libproxy-0.3.0-4.el6_3.x86_64
---> Package libreport-compat.x86_64 0:2.0.9-15.el6 will be installed
---> Package mesa-dri-filesystem.x86_64 0:9.0-0.8.el6_4.3 will be installed
---> Package mesa-dri1-drivers.x86_64 0:7.11-8.el6 will be installed
---> Package nss-tools.x86_64 0:3.14.3-4.el6_4 will be installed
---> Package python-paste-deploy1.5.noarch 0:1.5.0-5.el6 will be installed
---> Package samba-client.x86_64 0:3.6.9-160.3.el6rhs will be installed
---> Package samba-glusterfs.x86_64 0:3.6.9-160.3.el6rhs will be installed
---> Package samba-winbind.x86_64 0:3.6.9-160.3.el6rhs will be installed
---> Package systemtap-client.x86_64 0:1.8-7.el6 will be installed
---> Package systemtap-devel.x86_64 0:1.8-7.el6 will be installed
---> Package usbredir.x86_64 0:0.5.1-1.el6 will be installed
--> Processing Dependency: libusb-1.0.so.0()(64bit) for package: usbredir-0.5.1-1.el6.x86_64
--> Running transaction check
---> Package glibc.i686 0:2.12-1.107.el6_4.2 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.107.el6_4.2.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.107.el6_4.2.i686
---> Package libproxy-bin.x86_64 0:0.3.0-4.el6_3 will be installed
---> Package libproxy-python.x86_64 0:0.3.0-4.el6_3 will be installed
---> Package libselinux.i686 0:2.0.94-5.3.el6_4.1 will be installed
---> Package libusb1.x86_64 0:1.0.9-0.6.rc1.el6 will be installed
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.14.3-3.el6_4 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: augeas-libs-0.9.0-4.el6.x86_64 != augeas-libs-0.9.0-1.el6.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Comment 1 Sachidananda Urs 2013-09-04 04:42:39 EDT
Package in question:

augeas-libs-0.9.0-4.el6.x86_64 != augeas-libs-0.9.0-1.el6.i686
Comment 3 Anthony Towns 2013-09-06 17:13:07 EDT
(In reply to Sachidananda Urs from comment #1)
> Package in question:
> 
> augeas-libs-0.9.0-4.el6.x86_64 != augeas-libs-0.9.0-1.el6.i686

The problem here seems to have actually been that the new versions of vdsm-reg and vdsm-gluster were not available on rhnqa, and the old versions were blocking augeas-libs from upgrading properly. I've fixed this, and yum is upgrading RHS 2.0 to 2.1 successfully now.
Comment 4 Sachidananda Urs 2013-09-07 09:31:13 EDT
Upgraded from U6 to Big Bend successfully. Package version mismatches are not seen.
Comment 5 Scott Haines 2013-09-23 18:32:16 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.