Bug 1004227 - NetworkUser can't see all networks when he has system permissions.
NetworkUser can't see all networks when he has system permissions.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Moti Asayag
Meni Yakove
network
: Reopened, Triaged, ZStream
Depends On:
Blocks: 1008544
  Show dependency treegraph
 
Reported: 2013-09-04 04:53 EDT by Ondra Machacek
Modified: 2016-02-10 14:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 11:28:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2013-09-04 04:53:18 EDT
Description of problem:
When User has NetworkUser role on system, then he can't see all networks in
system. He can only see networks which are attached to cluster, and to vnic.

Version-Release number of selected component (if applicable):
sf20

How reproducible:
always

Steps to Reproduce:
1. Create 2 networks, network1 and network2.
2. Attach network1 to cluster.
3. Create vm and add vnic to this vm with network1.
4. Add user and add him NetworkUser role on system.
5. As user check /api/networks

Actual results:
User can see only network1, and he can't see network2.

Expected results:
User can see both networks.

Additional info:
Comment 1 Dan Kenigsberg 2013-09-16 08:17:17 EDT
(01:11:51 PM) masayag: https://bugzilla.redhat.com/show_bug.cgi?id=1004227 should be cloned for Z-stream and be closed on 3.3 as CURRENT_RELEASE
(01:12:30 PM) masayag: it is relevant only for 3.2 since there we used to have permissions on network while on 3.3 we set the user permissions on the vnic profiles
Comment 2 Arthur Berezin 2013-09-16 08:44:24 EDT
Is same behaviour experienced in UI?

Note You need to log in before you can comment on or make changes to this bug.