Bug 1004228 - cvs runs as init_t when cvs.socket is active
cvs runs as init_t when cvs.socket is active
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 1004161
  Show dependency treegraph
 
Reported: 2013-09-04 04:54 EDT by Milos Malik
Modified: 2014-06-17 22:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-77.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:35:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2013-09-04 04:54:44 EDT
Description of problem:

Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-73.el7.noarch
selinux-policy-devel-3.12.1-73.el7.noarch
selinux-policy-doc-3.12.1-73.el7.noarch
selinux-policy-minimum-3.12.1-73.el7.noarch
selinux-policy-mls-3.12.1-73.el7.noarch
selinux-policy-targeted-3.12.1-73.el7.noarch
cvs-inetd-1.11.23-31.el7.noarch
cvs-1.11.23-31.el7.x86_64

How reproducible:
always

Steps to Reproduce:
# systemctl enable cvs.socket
ln -s '/usr/lib/systemd/system/cvs.socket' '/etc/systemd/system/sockets.target.wants/cvs.socket'
# systemctl start cvs.socket
# systemctl status cvs.socket
cvs.socket - CVS Server Activation Socket
   Loaded: loaded (/usr/lib/systemd/system/cvs.socket; enabled)
   Active: active (listening) since Wed 2013-09-04 10:52:19 CEST; 5s ago
   Listen: [::]:2401 (Stream)
 Accepted: 0; Connected: 0

Sep 04 10:52:19 rhel70 systemd[1]: Listening on CVS Server Activation Socket.
# nc -v 127.0.0.1 2401
Ncat: Version 6.40 ( http://nmap.org/ncat )
Ncat: Connected to 127.0.0.1:2401.
^Z
[1]+  Stopped                 nc -v 127.0.0.1 2401
# ps -efZ | grep cvs
system_u:system_r:init_t:s0     root      6672     1  0 10:52 ?        00:00:00 /usr/bin/cvs -f --allow-root=/var/cvs pserver
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 6674 24725  0 10:52 pts/0 00:00:00 grep --color=auto cvs
# fg
nc -v 127.0.0.1 2401
^C
# 

Actual results:
 * cvs process is not labelled correctly

Expected results:
 * cvs process is labelled correctly
Comment 3 Daniel Walsh 2013-09-05 08:56:21 EDT
69d50ae175d9eefab754986a1c03b8b895a1117b fixes this in git.
Comment 5 Ludek Smid 2014-06-13 05:35:51 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.