Bug 1004307 - Clicking "Enable Jenkins builds" causes "We appear to be having technical difficulties"
Clicking "Enable Jenkins builds" causes "We appear to be having technical dif...
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 07:27 EDT by Dan Greaves
Modified: 2015-05-14 21:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 12:06:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Greaves 2013-09-04 07:27:59 EDT
Description of problem:

When I navigate to my app in the web console and click "Enable Jenkins builds", I am redirected to a page that says "We appear to be having technical difficulties".

The reference hash displayed at the bottom of the screen is  #7698325a8c0584e4c4bd6538a4c5a1c3.

This appears to be happening in a number of other circumstances too including reducing the minimum number of gears to use in the PHP cartridge.

Version-Release number of selected component (if applicable):

n/a

How reproducible:

I don't know whether this bug is specific to me but I simply go to the app and click "Enable Jenkins builds".

Steps to Reproduce:

1. Navigate to application
2. Click "Enable Jenkins builds"
3. Read resulting error page

Actual results:

An error page is displayed with reference #7698325a8c0584e4c4bd6538a4c5a1c3.

Expected results:

The "Enable Jenkins builds" wizard should appear.

Additional info:

n/a
Comment 1 Fabiano Franz 2013-09-10 12:06:13 EDT
Checking logs I found a 502 (proxy error) cause for #7698325a8c0584e4c4bd6538a4c5a1c3, so this was probably related to temporary outage of broker during a prod deploy. Closing this but can you please check if the error is still reproducible and if so, send the new reference id?
Comment 2 Dan Greaves 2013-09-10 13:31:13 EDT
Looks like it's working fine for me now. Might be worth outputting a bit more error information on the 502 page?

Seen as the majority (if not all) the users here are developers, I don't think that hiding error information has any benefit, especially when it comes to logging bugs.

Note You need to log in before you can comment on or make changes to this bug.