Bug 1004331 - Smbd crashed while doing "volume set stat-prefetch off" operation on the gluster volume
Smbd crashed while doing "volume set stat-prefetch off" operation on the glus...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Raghavendra Talur
Lalatendu Mohanty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 08:35 EDT by Lalatendu Mohanty
Modified: 2013-09-23 18:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-09-04 08:35:36 EDT
Description of problem:

Smbd crashed while doing "volume set stat-prefetch off" operation on the gluster volume

Version-Release number of selected component (if applicable):

[root@dhcp159-136 bricks]# rpm -qa | grep samba
samba-doc-3.6.9-160.3.el6rhs.x86_64
samba-debuginfo-3.6.9-160.3.el6rhs.x86_64
samba-winbind-3.6.9-160.3.el6rhs.x86_64
samba-glusterfs-3.6.9-160.3.el6rhs.x86_64
samba-swat-3.6.9-160.3.el6rhs.x86_64
samba-winbind-krb5-locator-3.6.9-160.3.el6rhs.x86_64
samba-domainjoin-gui-3.6.9-160.3.el6rhs.x86_64
samba-common-3.6.9-160.3.el6rhs.x86_64
samba-3.6.9-160.3.el6rhs.x86_64
samba-client-3.6.9-160.3.el6rhs.x86_64
samba-winbind-devel-3.6.9-160.3.el6rhs.x86_64
samba4-libs-4.0.0-55.el6.rc4.x86_64
samba-winbind-clients-3.6.9-160.3.el6rhs.x86_64


[root@dhcp159-136 bricks]# rpm -qa | grep gluster
glusterfs-geo-replication-3.4.0.30rhs-2.el6rhs.x86_64
samba-glusterfs-3.6.9-160.3.el6rhs.x86_64
gluster-swift-container-1.8.0-6.11.el6rhs.noarch
glusterfs-libs-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-3.4.0.30rhs-2.el6rhs.x86_64
glusterfs-server-3.4.0.30rhs-2.el6rhs.x86_64
gluster-swift-proxy-1.8.0-6.11.el6rhs.noarch
gluster-swift-account-1.8.0-6.11.el6rhs.noarch
glusterfs-rdma-3.4.0.30rhs-2.el6rhs.x86_64
gluster-swift-plugin-1.8.0-6.el6rhs.noarch
vdsm-gluster-4.10.2-23.0.1.el6rhs.noarch
glusterfs-api-3.4.0.30rhs-2.el6rhs.x86_64
gluster-swift-1.8.0-6.11.el6rhs.noarch
glusterfs-fuse-3.4.0.30rhs-2.el6rhs.x86_64
gluster-swift-object-1.8.0-6.11.el6rhs.noarch

How reproducible:
Intermittent

Steps to Reproduce:

It a rare issue and I have just seen it once in last few days testing

1.Create a gluster volume, start the volume.
2. mount the samba share on a window7 client and do some I/O
3. On the rhs node run "gluster v set <vol name> stat-prefetch off" 
4. On the Win mount point do some acl changes on the folder

Actual results:

smbd core got generated. 

Expected results:

smbd should not have crashed

Additional info:

We tried to get the back trace from the core but it was truncated. Below are the messages present in /var/log/messages
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

4 06:36:03 dhcp159-136 smbd[18980]:   glfs_stat(./..) failed: No data available
Sep  4 07:15:32 dhcp159-136 smbd[18980]: [2013/09/04 07:15:32.957732,  0] lib/fault.c:48(fault_report)
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   Skipping user change - already user
Sep  4 07:15:32 dhcp159-136 smbd[18980]: [2013/09/04 07:15:32.958441,  0] lib/fault.c:50(fault_report)
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   #012smb2: write size (8192) too small for minimum aio_write of 0
Sep  4 07:15:32 dhcp159-136 smbd[18980]: [2013/09/04 07:15:32.958655,  0] lib/fault.c:51(fault_report)
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   is_locked: optimisation - exclusive oplock on file testvol3/testacl/bd0
Sep  4 07:15:32 dhcp159-136 smbd[18980]: [2013/09/04 07:15:32.958794,  0] lib/util.c:1117(smb_panic)
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   strict_lock_default: flavour = WINDOWS_LOCK brl start=745472 len=8192 unlocked for fnum 9975 file testvol3/testacl/bd0
Sep  4 07:15:32 dhcp159-136 smbd[18980]: [2013/09/04 07:15:32.995563,  0] lib/util.c:1221(log_stack_trace)
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   smb2: fnum=[9975/testvol3/testacl/bd0] length=8192 offset=0 wrote=8192
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   smb2: fnum=[9975/testvol3/testacl/bd0] length=8192 offset=0 wrote=8192#012BACKTRACE: 16 stack frames:
Sep  4 07:15:32 dhcp159-136 smbd[18980]: [2013/09/04 07:15:32.999076,  0] lib/fault.c:372(dump_core)
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   smb2_set_operation_credit: requested 1, granted 1, current possible/max 482/512, total granted/max/low/range 31/8192/383511/31
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   smb2_set_operation_credit: requested 1, granted 1, current possible/max 482/512, total granted/max/low/range 31/8192/383511/31#012dumping core in /var/log/core
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   smbd_smb2_request_reply: sending...
Sep  4 07:15:32 dhcp159-136 smbd[18980]: 
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   #011req->in.vector[0].iov_len = 4
Sep  4 07:15:32 dhcp159-136 smbd[18980]:   #011req->in.vector[1].iov_len = 64
Sep  4 07:15:39 dhcp159-136 smbd[20814]: [2013/09/04 07:15:39.435597,  0] modules/vfs_glusterfs.c:280(vfs_gluster_connect)
Sep  4 07:15:39 dhcp159-136 smbd[20814]:   testvol3: Initialized volume from server localhost
Sep  4 07:15:39 dhcp159-136 smbd[20814]: [2013/09/04 07:15:39.674559,  0] modules/vfs_glusterfs.c:280(vfs_gluster_connect)
Sep  4 07:15:39 dhcp159-136 smbd[20814]:   testvol4: Initialized volume from server localhost
Sep  4 07:16:19 dhcp159-136 smbd[20814]: [2013/09/04 07:16:19.351774,  0] modules/vfs_glusterfs.c:576(vfs_gluster_stat)
Sep  4 07:16:19 dhcp159-136 smbd[20814]:   glfs_stat(./..) failed: No data available
Sep  4 07:19:51 dhcp159-136 smbd[20814]: [2013/09/04 07:19:51.997875,  0] modules/vfs_glusterfs.c:576(vfs_gluster_stat)
Sep  4 07:19:51 dhcp159-136 smbd[20814]:   glfs_stat(.) failed: Input/output error
Sep  4 07:19:54 dhcp159-136 smbd[20814]: [2013/09/04 07:19:54.516451,  0] modules/vfs_glusterfs.c:576(vfs_gluster_stat)
Sep  4 07:19:54 dhcp159-136 smbd[20814]:   glfs_stat(.) failed: Input/output error
Sep  4 07:19:55 dhcp159-136 smbd[20814]: [2013/09/04 07:19:55.715156,  0] modules/vfs_glusterfs.c:576(vfs_gluster_stat)
Sep  4 07:19:55 dhcp159-136 smbd[20814]:   glfs_stat(.) failed: Input/output error
Sep  4 07:19:55 dhcp159-136 smbd[20814]: [2013/09/04 07:19:55.722249,  0] modules/vfs_glusterfs.c:576(vfs_gluster_stat)
Sep  4 07:19:55 dhcp159-136 smbd[20814]:   glfs_stat(testvol4/New folder) failed: Input/output error
Sep  4 07:19:55 dhcp159-136 smbd[20814]: [2013/09/04 07:19:55.722569,  0] modules/vfs_glusterfs.c:576(vfs_gluster_stat)


From /var/log/glusterfs/.cmd_log_history 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

[2013-09-04 11:02:56.395231]  : v set testvol3 stat-prefetch off : SUCCESS
[2013-09-04 11:15:33.023743]  : v set testvol4 stat-prefetch off : SUCCESS
[2013-09-04 11:19:43.680759]  : v set testvol4 stat-prefetch on : SUCCESS
Comment 2 Vivek Agarwal 2013-09-05 13:01:16 EDT
Per discussion with Sayan, recommend "volume set stat-prefetch off", need to be documented
Comment 3 Lalatendu Mohanty 2013-09-06 05:22:21 EDT
I am not getting core file any more. Hence marking this as verified.

glusterfs-server-3.4.0.31rhs-1
samba-common-3.6.9-160.3
Comment 4 Scott Haines 2013-09-23 18:32:17 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.