Bug 100436 - Request of Apache-2.0.47 and mod_logio
Summary: Request of Apache-2.0.47 and mod_logio
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: httpd (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL: http://httpd.apache.org/
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-22 12:50 UTC by Dirk Nehring
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version: 2.0.47-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-23 13:55:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dirk Nehring 2003-07-22 12:50:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 7.10  [en]

Description of problem:
Apache 2.0.45 has 3 important bugs:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0192
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0253
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0254

Also, you should recompile Apache with the mod_logio module enabled. This module 
is included since 2.0.45 and  provides the logging of input and output number of 
bytes received/sent per request. It can be enabled by

--enable-logio


Version-Release number of selected component (if applicable):
httpd-2.0.45-14

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Please try to keep Apache releases in line with the official releases from the 
Apache Group.

Comment 1 Joe Orton 2003-07-23 13:55:03 UTC
2.0.47 is now in Raw Hide and includes mod_logio.


Note You need to log in before you can comment on or make changes to this bug.