Bug 100438 - Vim crashes pasting buffers
Vim crashes pasting buffers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.3
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 09:14 EDT by Stian Skjelstad
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 10:23:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb output (1.38 KB, text/plain)
2003-07-30 10:24 EDT, Stian Skjelstad
no flags Details

  None (edit)
Description Stian Skjelstad 2003-07-22 09:14:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020827

Description of problem:
Pasting a buffer over a marked text, crashes vim (and you must send it a signal
9 to kill it). If you send a regular kill signals, it dumps stuff to console,
but don't die.

[root@pluto libpackage]# vim extract.c 
Vim: Caught deadly signal SEGV
Vim: preserving files...
Vim: Double signal, exiting
Killed


Version-Release number of selected component (if applicable):
6.1-18.7x.2

How reproducible:
Always

Steps to Reproduce:
* Open a file full of stuff
* Mark text (visual mode) and yank it
* Mark some new text, and press "p" (paste) while the text is marked

Actual Results:  It crashes

Expected Results:  Replace the selected area with the text in the buffer

Additional info:

I have testes this on a three up to date redhat 7.3 boxes. (One vanilla, one
rebuilt repaired one, and one upgraded from 7.1 where vim just froze the screen
and not showing any SEGV text at all)


Reopen file and restoring swap-file results in some random junk at the place you
were working.
Comment 1 Karsten Hopp 2003-07-30 09:46:27 EDT
Please set the corefile size to unlimited  (maybe only allowed for root) with ulimit -c 9999999 
and try to reproduce the bug. This will create a core-file in the current directory. 
 
Then run 
gdb /usr/bin/vim corefile_name, enter 'bt <enter>' and add the output to this bugreport. 
Comment 2 Karsten Hopp 2003-07-30 09:47:16 EDT
and please add the output of "echo $LANG", too 
Comment 3 Stian Skjelstad 2003-07-30 10:24:30 EDT
Created attachment 93258 [details]
gdb output

vim doesn't generate core files since it has a SIGSEGV handler that works (but
hangs), but vim can be run directly from gdb (opt. with remote tty). The $LANG
is set to en_US.

The crash only occures if the buffer you want to overwrite contains minimum one
line-break.
Comment 4 Karsten Hopp 2004-07-21 10:23:38 EDT
this should be fixed in current releases 

Note You need to log in before you can comment on or make changes to this bug.