Bug 1004406 - Welcome page redirection is not working (in case of 404)
Welcome page redirection is not working (in case of 404)
Status: CLOSED DUPLICATE of bug 987971
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Alon Bar-Lev
Pavel Stehlik
integration
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 10:51 EDT by Pavel Stehlik
Modified: 2013-09-23 06:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 05:40:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Stehlik 2013-09-04 10:51:46 EDT
Description of problem:
 Currently is redirection broken again - in case of wrong address WP (WelcomePage) is not shown. One place is in Apache ( /etc/httpd/conf.d/ovirt-engine-root-redirect.conf ), 2nd place is somewhere in webadmin/UserPortal apps).
 I think both are infra matters so no need 2 BZs for it I guess.


Version-Release number of selected component (if applicable):
is13

How reproducible:
100%

Steps to Reproduce:
1. install new rhevm
2a. try: http[s]://10.34.63.19/ovirt-some, 
2b. try: http[s]://10.34.63.19/webadmin/webadmin/some.html (although custom page is shown to user - it's not redirected {like in earlier versions}).

Actual results:
a) 404 Apache err
b) in webadmin/UP is custom page, which is not redirected

Expected results:
we should redirect automatically to WP 

Additional info:
Comment 2 Alon Bar-Lev 2013-09-08 05:40:09 EDT
root issue is dup of bug#987971

404 redirection is disabled per[1]

[1] http://gerrit.ovirt.org/#/c/18196/
Comment 3 Alon Bar-Lev 2013-09-08 05:40:59 EDT
As there are two issues, and one already reported, I am closing this and not marking as dup.
Comment 4 Pavel Stehlik 2013-09-23 06:00:19 EDT

*** This bug has been marked as a duplicate of bug 987971 ***

Note You need to log in before you can comment on or make changes to this bug.