Bug 1004410 - remmina needs an update due to freerdp changes
remmina needs an update due to freerdp changes
Status: CLOSED DUPLICATE of bug 1107011
Product: Fedora
Classification: Fedora
Component: remmina (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Alexeev
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2013-09-04 11:01 EDT by Jeffrey C. Ollie
Modified: 2015-10-04 13:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-06-11 17:44:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeffrey C. Ollie 2013-09-04 11:01:37 EDT
FreeRDP was updated in f20+ which broke the Remmina RDP plugin.  I tried rebuilding the RPM but there are API changes in FreeRDP.  The Remmina upstream may have patches to fix that but I'm not sure.
Comment 1 Simone Caronni 2013-09-11 03:27:43 EDT
FreeRDP 1.1.0-beta1 was pushed to Fedora 20 by mistake on 2013-09-01, I'm now reverting the change and push an update with 1.0.2.

1.1.0-beta1 with the API change is slated for Fedora 21.
Comment 2 Christoph Wickert 2014-05-22 07:35:20 EDT
Assigning bug to new package maintainer.
Comment 3 Jeffrey C. Ollie 2014-06-11 16:02:13 EDT
How is this fixed?  The latest build in Koji failed, so the version in rawhide is still broken.  In fact, it hasn't built correctly since December of 2013.

Comment 4 Simone Caronni 2014-06-11 17:44:50 EDT
This bug is for Fedora 20. In Fedora 20, the package is built, available, installable and working.

When the ticket was opened, there had been a push into Fedora 20 of version 1.1.0 by Mads, which was then reverted to 1.0.2 by bumping the epoch to 1.

In Fedora 21 the story is different, it does not build, but we're working on it. It requires FreeRDP git, and some Remmina features are broken. There is another bug for this (and various mail discussions):


*** This bug has been marked as a duplicate of bug 1107011 ***
Comment 5 Pavel Alexeev 2015-10-04 13:21:52 EDT
Work was done by linked issue.

Note You need to log in before you can comment on or make changes to this bug.