Bug 1004440 - Allow to send Ctrl+Alt+Del using a keyboard shortcut
Allow to send Ctrl+Alt+Del using a keyboard shortcut
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Marc-Andre Lureau
Desktop QE
:
: 1008832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 12:02 EDT by Christophe Fergeau
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.6-8.el6_4
Doc Type: Bug Fix
Doc Text:
Previously Windows always captured the Ctrl+Alt+Del key sequence and did not let applications intercept it. It was not possible for mingw-virt-viewer to catch Ctrl+Alt+Del and pass it to the guest when the guest was in focus. This key combination can now be passed to the guest using the Ctrl+Alt+End key combination.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 09:47:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2013-09-04 12:02:59 EDT
On Windows, ctrl+alt+del is caught by the OS and can't be intercepted by applications. This means that virt-viewer cannot steal ctrl+alt+del from the client OS and pass it to the guest. We already have a menu entry to send such a key combination to the guest, but a way to do it from the keyboard would be nice as well. spicec used to be able to send it through ctrl+alt+end from what I was told.
It would be nice if we also had a keyboard shortcut for ctrl+alt+del in virt-viewer as it can be more convenient than having to reach for the mouse and a menu entry.
Comment 1 Christophe Fergeau 2013-09-04 12:06:07 EDT
Jonathon sent a patch series upstream:
https://www.redhat.com/archives/virt-tools-list/2013-August/msg00209.html
Comment 3 Tomas Jamrisko 2013-10-10 10:41:57 EDT
Suggest moving this back to ASSIGNED as:

Ctrl-alt-end sometimes conflicts with the default release cursor which is ctrl-alt.  
It happens consistently when the agent is not running, otherwise for some reason  noticeable only after maximizing the window.

Note that:
This causes no issues if the default is overridden, e.g. RHEVM and Shift+F12.
Comment 4 Marc-Andre Lureau 2013-10-10 11:07:57 EDT
(In reply to Tomas Jamrisko from comment #3)

> Note that:
> This causes no issues if the default is overridden, e.g. RHEVM and Shift+F12.

If it works with default RHEVM, I suggest a document note, and a new bug upstream for the ctrl-alt conflict.
Comment 5 Jonathon Jongsma 2013-10-11 11:29:11 EDT
(In reply to Marc-Andre Lureau from comment #4)
> (In reply to Tomas Jamrisko from comment #3)
> 
> > Note that:
> > This causes no issues if the default is overridden, e.g. RHEVM and Shift+F12.
> 
> If it works with default RHEVM, I suggest a document note, and a new bug
> upstream for the ctrl-alt conflict.

That sounds reasonable to me as well.
Comment 9 Tomas Jamrisko 2013-10-15 12:03:36 EDT
(In reply to errata-xmlrpc from comment #7)
 
> Switching back to ON_QA as I noticed that ctrl alt end doesn't work when in
> fullscreen. at least in Windows 8, it seems to work fine with 7, do you want
> to fix it now or report another bug?

Ok, so had a shot at physically installed 7 instead of a VM and it's broken there as well.
Comment 10 David Blechter 2013-10-15 13:48:42 EDT
(In reply to Tomas Jamrisko from comment #9)
> (In reply to errata-xmlrpc from comment #7)
>  
> > Switching back to ON_QA as I noticed that ctrl alt end doesn't work when in
> > fullscreen. at least in Windows 8, it seems to work fine with 7, do you want
> > to fix it now or report another bug?
> 
> Ok, so had a shot at physically installed 7 instead of a VM and it's broken
> there as well.

What is the reason to keep it in N_QA?
should it be moved to ASSIGNED?
Comment 11 Jonathon Jongsma 2013-10-15 14:02:28 EDT
I just posted another patch to the mailing list that should fix the issue in fullscreen: https://www.redhat.com/archives/virt-tools-list/2013-October/msg00098.html
Comment 14 David Blechter 2013-11-08 09:31:39 EST
*** Bug 1008832 has been marked as a duplicate of this bug. ***
Comment 16 Charlie 2013-11-27 20:26:18 EST
This bug is currently attached to errata RHEA-2013:15512. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 17 Christophe Fergeau 2013-12-17 04:59:55 EST
Cheryn, the doc text is not fully accurate, the last sentence should read "This key combination can now be passed to the guest using the Ctrl+Alt+End key combination" or something similar.
Comment 18 Cheryn Tan 2013-12-18 02:24:46 EST
Thanks for the correction Christophe, I've changed it according to your suggestion.
Comment 20 errata-xmlrpc 2014-01-21 09:47:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0034.html

Note You need to log in before you can comment on or make changes to this bug.