Bug 100446 - Extracting large tar files via SSH causes shell to crash (Oops)
Extracting large tar files via SSH causes shell to crash (Oops)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 09:55 EDT by ZeRo
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-27 08:04:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ZeRo 2003-07-22 09:55:42 EDT
Description of problem:  When extracting large tar files (approximately 800MB 
and higher), causes the linux kernel to produce an Oops and crash the shell.  
The Oops can occur up to 2-3 hours after the initial extraction of the tar file.


Version-Release number of selected component (if applicable):


How reproducible:  Using a ssh shell, log into the linux server and extract a 
large tar file (approximately 800MB or higher).  The extract syntax is: tar -
xvf file.tar.  If the tar file is incomplete, the shell will crash 
immediately.  Otherwise, the shell seems to be unable to recover from the 
extraction process and cause an Oops in the kernel up to 2-3 hours later.  It 
appears that the background processes become corrupt after heavy I/O activity.


Steps to Reproduce:
1.  Copy large tar file to system (800MB or higher).
2.  Log into machine using a SSH shell and type: tar -xvf filename.tar (to 
extract file)
3.  kernel will cause an Oops and the shell will crash up to 2-3 hours later.  
Note: The kernal will Oops and crash immediately if the large tar file is 
corrupt or unfinished.
    
Actual results:


Expected results:


Additional info:
Comment 1 Peter Vrabec 2004-10-27 08:04:17 EDT
It works for me on FC2.
But it might be a kernel bug or hw problem, don't u thing so?

Note You need to log in before you can comment on or make changes to this bug.