Bug 1004487 - can't create any quickstart from the UI.
can't create any quickstart from the UI.
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 14:06 EDT by Peter Ruan
Modified: 2015-05-14 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-01 16:02:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2013-09-04 14:06:02 EDT
Description of problem:
  User can't create any apps that's based on a quickstart template.

Version-Release number of selected component (if applicable):
built from Augst 21 2013
How reproducible:
always

Steps to Reproduce:
1. go to origin UI
2. select any of the quickstart templates 
3.

Actual results:
the Create Application button does nothing.

Expected results:


Additional info:
Comment 2 weiwei jiang 2014-01-02 05:47:30 EST
Tried setup a latest origin according to https://openshift.github.io/documentation/oo_deployment_guide_vm.html.

And when create a django quickstart it failed.
Log refer follow.

2014-01-02 18:42:00.378 [INFO ] Started GET "/broker/rest/user.json" for 127.0.0.1 at 2014-01-02 18:42:00 +0800 (pid:2766)
2014-01-02 18:42:00.381 [INFO ] Processing by UserController#show as JSON (pid:2766)
2014-01-02 18:42:00.385 [INFO ] Completed 200 OK in 4ms (Views: 0.4ms) (pid:2766)
2014-01-02 18:42:00.390 [INFO ] Started GET "/broker/rest/domains.json?include=application_info" for 127.0.0.1 at 2014-01-02 18:42:00 +0800 (pid:2766)
2014-01-02 18:42:00.391 [INFO ] Processing by DomainsController#index as JSON (pid:2766)
2014-01-02 18:42:00.391 [INFO ] Parameters: {"include"=>"application_info"} (pid:2766)
2014-01-02 18:42:00.396 [INFO ] Completed 200 OK in 5ms (Views: 0.6ms) (pid:2766)
2014-01-02 18:42:00.402 [INFO ] Started GET "/broker/rest/domain/asdfasdfsd.json" for 127.0.0.1 at 2014-01-02 18:42:00 +0800 (pid:2766)
2014-01-02 18:42:00.403 [INFO ] Processing by DomainsController#show as JSON (pid:2766)
2014-01-02 18:42:00.403 [INFO ] Parameters: {"id"=>"asdfasdfsd"} (pid:2766)
2014-01-02 18:42:00.509 [INFO ] Completed 200 OK in 105ms (Views: 0.6ms) (pid:2766)
2014-01-02 18:42:00.516 [INFO ] Started POST "/broker/rest/domain/asdfasdfsd/applications.json" for 127.0.0.1 at 2014-01-02 18:42:00 +0800 (pid:2766)
2014-01-02 18:42:00.519 [INFO ] Processing by ApplicationsController#create as JSON (pid:2766)
2014-01-02 18:42:00.519 [INFO ] Parameters: {"cartridges"=>["python-2.7"], "domain_id"=>"asdfasdfsd", "gear_profile"=>"small", "initial_git_url"=>"git://github.com/openshift/django-example.git", "name"=>"django", "scale"=>"false"} (pid:2766)
2014-01-02 18:43:15.856 [ERROR] An invalid exit code (131) was returned from the server broker.example.com.  This indicates an unexpected problem during the execution of your request. (pid:2766)
2014-01-02 18:43:15.858 [ERROR] ["/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.18.0/lib/openshift/mcollective_application_container_proxy.rb:2727:in `parse_result'", "/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.18.0/lib/openshift/mcollective_application_container_proxy.rb:2894:in `run_cartridge_command'", "/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.18.0/lib/openshift/mcollective_application_container_proxy.rb:807:in `add_component'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/gear.rb:167:in `add_component'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/pending_ops/add_comp_op.rb:11:in `execute'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/pending_app_op_group.rb:107:in `block in execute'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/pending_app_op_group.rb:96:in `each'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/pending_app_op_group.rb:96:in `execute'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/application.rb:1564:in `run_jobs'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/application.rb:684:in `block in add_features'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/application.rb:1630:in `run_in_application_lock'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/application.rb:666:in `add_features'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/models/application.rb:251:in `create_app'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/app/controllers/applications_controller.rb:157:in `create'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/implicit_render.rb:4:in `send_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/base.rb:167:in `process_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/rendering.rb:10:in `process_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/callbacks.rb:18:in `block in process_action'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:481:in `block in _run__1264953757386894969__process_action__288153337501099224__callbacks'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:215:in `block in _conditional_callback_around_398'", "/usr/share/gems/gems/openshift-origin-controller-1.18.0/lib/openshift/controller/action_log.rb:80:in `set_logged_request'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:214:in `_conditional_callback_around_398'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:403:in `_run__1264953757386894969__process_action__288153337501099224__callbacks'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in `__run_callback'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:385:in `_run_process_action_callbacks'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:81:in `run_callbacks'", "/usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/callbacks.rb:17:in `process_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/rescue.rb:29:in `process_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/instrumentation.rb:30:in `block in process_action'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/notifications.rb:123:in `block in instrument'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/notifications/instrumenter.rb:20:in `instrument'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/notifications.rb:123:in `instrument'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/instrumentation.rb:29:in `process_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/params_wrapper.rb:207:in `process_action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/base.rb:121:in `process'", "/usr/share/gems/gems/actionpack-3.2.13/lib/abstract_controller/rendering.rb:45:in `process'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal.rb:203:in `dispatch'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal/rack_delegation.rb:14:in `dispatch'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_controller/metal.rb:246:in `block in action'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:73:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:73:in `dispatch'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:36:in `call'", "/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:68:in `block in call'", "/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `each'", "/usr/share/gems/gems/journey-1.0.4/lib/journey/router.rb:56:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/routing/route_set.rb:612:in `call'", "/usr/share/gems/gems/mongoid-3.1.4/lib/rack/mongoid/middleware/identity_map.rb:34:in `block in call'", "/usr/share/gems/gems/mongoid-3.1.4/lib/mongoid/unit_of_work.rb:39:in `unit_of_work'", "/usr/share/gems/gems/mongoid-3.1.4/lib/rack/mongoid/middleware/identity_map.rb:34:in `call'", "/usr/share/gems/gems/sass-3.2.6/lib/sass/plugin/rack.rb:54:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/best_standards_support.rb:17:in `call'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/etag.rb:23:in `call'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/conditionalget.rb:35:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/head.rb:14:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/params_parser.rb:21:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/flash.rb:242:in `call'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:210:in `context'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/session/abstract/id.rb:205:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/cookies.rb:341:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/callbacks.rb:28:in `block in call'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in `_run__540759596598042478__call__3389991180419079524__callbacks'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:405:in `__run_callback'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:385:in `_run_call_callbacks'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/callbacks.rb:81:in `run_callbacks'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/callbacks.rb:27:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/remote_ip.rb:31:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/debug_exceptions.rb:16:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/show_exceptions.rb:56:in `call'", "/usr/share/gems/gems/railties-3.2.13/lib/rails/rack/logger.rb:32:in `call_app'", "/usr/share/gems/gems/railties-3.2.13/lib/rails/rack/logger.rb:16:in `block in call'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/tagged_logging.rb:22:in `tagged'", "/usr/share/gems/gems/railties-3.2.13/lib/rails/rack/logger.rb:16:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/request_id.rb:22:in `call'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/methodoverride.rb:21:in `call'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/runtime.rb:17:in `call'", "/usr/share/gems/gems/activesupport-3.2.13/lib/active_support/cache/strategy/local_cache.rb:72:in `call'", "/usr/share/gems/gems/rack-1.4.5/lib/rack/lock.rb:15:in `call'", "/usr/share/gems/gems/actionpack-3.2.13/lib/action_dispatch/middleware/static.rb:63:in `call'", "/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:136:in `forward'", "/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:143:in `pass'", "/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:155:in `invalidate'", "/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:71:in `call!'", "/usr/share/gems/gems/rack-cache-1.2/lib/rack/cache/context.rb:51:in `call'", "/usr/share/gems/gems/railties-3.2.13/lib/rails/engine.rb:479:in `call'", "/usr/share/gems/gems/railties-3.2.13/lib/rails/application.rb:223:in `call'", "/usr/share/gems/gems/railties-3.2.13/lib/rails/railtie/configurable.rb:30:in `method_missing'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/request_handler.rb:97:in `process_request'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_request_handler.rb:521:in `accept_and_process_next_request'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:206:in `start_request_handler'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:171:in `block in handle_spawn_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/utils.rb:470:in `safe_fork'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:166:in `handle_spawn_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:180:in `start'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/rack/application_spawner.rb:129:in `start'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:253:in `block (2 levels) in spawn_rack_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:132:in `lookup_or_add'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:246:in `block in spawn_rack_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:82:in `block in synchronize'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:244:in `spawn_rack_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:137:in `spawn_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/spawn_manager.rb:275:in `handle_spawn_application'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:357:in `server_main_loop'", "/usr/share/gems/gems/passenger-3.0.21/lib/phusion_passenger/abstract_server.rb:206:in `start_synchronously'", "/usr/share/gems/gems/passenger-3.0.21/helper-scripts/passenger-spawn-server:102:in `<main>'"] (pid:2766)
2014-01-02 18:43:15.860 [ERROR] Encountered error during execute 'An invalid exit code (131) was returned from the server broker.example.com.  This indicates an unexpected problem during the execution of your request.' (pid:2766)
2014-01-02 18:43:35.716 [INFO ] Completed 500 Internal Server Error in 95196ms (Views: 0.4ms) (pid:2766)
Comment 3 Peter Ruan 2014-05-01 16:02:20 EDT
works for me with release 3

Note You need to log in before you can comment on or make changes to this bug.